Data table viz excludes records where bucket term is blank [SOLVED]


(Chris) #1

The data table is excluding rows where bucket term is blank.

For example, assume I have the following data:
{"id":1, "item":"widget1", "type":"toy", "color":"blue", "price":5.05}
{"id":2, "item":"widget2", "type":"toy", "color":"", "price":3.15}

If I create a data table, there will be a count of two.
If I split the rows with buckets on the term "color", I get one row with a count of 1 for blue.

Shouldn't there also be a second row with a blank color and a count of 1?

I'm seeing this with Kibana 4.4.0, window 7 and IE 11.


(Tanya Bragin) #2

You'd need support for "missing" in Kibana Terms agg treatment, which is not there at the moment: https://github.com/elastic/kibana/issues/1961


(Chris) #3

I see now that this can be done by selecting "Show partial rows" on the "Options" table of the data table visualization.


(Tanya Bragin) #4

What version are you using? That option makes no difference for me.


(Chris) #5

I'm using Kibana 4.4.0 and Elasticsearch 2.2.0.

In your case is the field present with an empty string value, or is the field missing altogether? In my case the field is present with an empty string, e.g., {"key":""}


(Tanya Bragin) #6

Same here, odd. Maybe related to this: https://github.com/elastic/kibana/issues/4765


(system) #7