Datatable visualization - Trim the time from timestamp


#1

I have created a datatable visualization to show per day logcount using DateHistogram. The timestamp is showing as - August 24th 2016, 00:00:00.000. Is there any way to trim the time part from this?
Version: Kibana 4.5.2 , ES 2.3.4


(Lee Drengenberg) #2

If you go to Settings > Advanced, you can change the dateFormat from MMMM Do YYYY, HH:mm:ss.SSS to something like MMMM Do YYYY. But note that this will affect your date fields throughout all of Kibana.

But it looks like dateFormat:scaled is the existing setting that should automatically do what you're asking for.

"Values that define the format used in situations where timebased data is rendered in order, and formatted timestamps should adapt to the interval between measurements. Keys are ISO8601 intervals."

[
  ["", "HH:mm:ss.SSS"],
  ["PT1S", "HH:mm:ss"],
  ["PT1M", "HH:mm"],
  ["PT1H",
      "YYYY-MM-DD HH:mm"],
  ["P1DT", "YYYY-MM-DD"],
  ["P1YT", "YYYY"]
]

Those settings work for a line chart but not for the data table visualization.
I think this is a bug and I created a new issue here; https://github.com/elastic/kibana/issues/8076
Feel free to comment or add anything I missed.

Regards,
Lee


#3

Thank you for the update. I wanted the date format to be changed in the datatable visualization only, not throughout kibana.
Also am wondering whether I can achieve this through json script?
Version: Kibana 4.5.2 , ES 2.3.4


(system) #4