Date_detection setting ignored

I have JSON being fed to ES by logstash. I have two templates for the
logstash indices and:

  • in the first template, a field "rawMsgTS" is explicitly declared as
    "string"
  • both templates have date_detection set to "false"

Templates:
http://pastebin.com/NvAeUGDg

But ES still tries to parse the field "rawMsgTS" as a data and bombs :frowning:

What am I doing wrong?

Thanks,

  • Tim

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/a90dbdb6-d7c1-450d-bf74-7e8c286c3ec6%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Never mind, I was expecting mappings/templates to take effect on an open
index. Once I deleted the index, I saw that the updated templates/mappings
get applied at index creation time.

On Friday, April 3, 2015 at 4:09:22 PM UTC-7, sec...@gmail.com wrote:

I have JSON being fed to ES by logstash. I have two templates for the
logstash indices and:

  • in the first template, a field "rawMsgTS" is explicitly declared as
    "string"
  • both templates have date_detection set to "false"

Templates:
http://pastebin.com/NvAeUGDg

But ES still tries to parse the field "rawMsgTS" as a data and bombs :frowning:

What am I doing wrong?

Thanks,

  • Tim

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/3f23bdd1-8279-4d3b-8db3-c1be33e3fc52%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.