Default index setting gets overwritten in Kibana3. How do I prevent this?


(Trekr5) #1

Hello,

My environment at work is Chef, Elasticsearch and Kibana 3.

I have a situation whereby the default index pattern is [logstash-]YYYY.MM.DD. However I've created a new index pattern named [application-log-]YYYY.MM.DD and want my Kibana3 to use this as the default index pattern.

However when I set this up in Kibana3 (Configure dashboard > index > index settings > and put in the new pattern index pattern, [application-log-]YYYY.MM.DD
), everytime a chef run occurs, this gets overwritten and it is now set back to [logstash-]YYYY.MM.DD.

Where do I set this up to ensure that the new index pattern pattern is used as the default for my Kibana 3 dashboard so that it doesn't get overwritten?

BTW, the new index pattern exists in Elasticsearch and works so I do have indices being created using it.

Thanks


(Mark Walkom) #2

This sounds like a Chef problem, why is it over writing on every run?


(system) #3