Default script language


(Jettro Coenradie) #1

Hi,
I was playing around with the new scripting support in 1.3. In the
documentation is stated that groovy is now the default language. This is
not true for all situations. The following query for instance is returning
a message about the use of mvel. I have to explicitly set the lang to
groovy. In the query. Am I missing something?

http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/modules-scripting.html

GET mymusic/_search
{
"query": {
"function_score": {
"query": {
"range": {
"year": {
"gte": 2000
}
}
},
"functions": [
{
"script_score": {
"script": "_score * doc['year'].value"
}
}
]
}
}
}

The response for this query is:
ScriptException[dynamic scripting for [mvel] disabled]

thanks, Jettro

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/b518a387-a02c-40ac-af7f-01ff41f50bc3%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(David Pilato) #2

Thanks. Tested. Issue opened here: https://github.com/elasticsearch/elasticsearch/issues/7029

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 25 juillet 2014 à 10:05:43, Jettro Coenradie (jettro.coenradie@gmail.com) a écrit:

Hi,
I was playing around with the new scripting support in 1.3. In the documentation is stated that groovy is now the default language. This is not true for all situations. The following query for instance is returning a message about the use of mvel. I have to explicitly set the lang to groovy. In the query. Am I missing something?

http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/modules-scripting.html

GET mymusic/_search
{
"query": {
"function_score": {
"query": {
"range": {
"year": {
"gte": 2000
}
}
},
"functions": [
{
"script_score": {
"script": "_score * doc['year'].value"
}
}
]
}
}
}

The response for this query is:
ScriptException[dynamic scripting for [mvel] disabled]

thanks, Jettro

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/b518a387-a02c-40ac-af7f-01ff41f50bc3%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/etPan.53d214fd.2cd89a32.13e40%40MacBook-Air-de-David.local.
For more options, visit https://groups.google.com/d/optout.


(David Pilato) #3

Actually mvel is still the default for 1.3.0.
groovy will be the default in 1.4.0.

We will fix the doc.

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 25 juillet 2014 à 10:27:44, David Pilato (david@pilato.fr) a écrit:

Thanks. Tested. Issue opened here: https://github.com/elasticsearch/elasticsearch/issues/7029

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 25 juillet 2014 à 10:05:43, Jettro Coenradie (jettro.coenradie@gmail.com) a écrit:

Hi,
I was playing around with the new scripting support in 1.3. In the documentation is stated that groovy is now the default language. This is not true for all situations. The following query for instance is returning a message about the use of mvel. I have to explicitly set the lang to groovy. In the query. Am I missing something?

http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/modules-scripting.html

GET mymusic/_search
{
"query": {
"function_score": {
"query": {
"range": {
"year": {
"gte": 2000
}
}
},
"functions": [
{
"script_score": {
"script": "_score * doc['year'].value"
}
}
]
}
}
}

The response for this query is:
ScriptException[dynamic scripting for [mvel] disabled]

thanks, Jettro

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/b518a387-a02c-40ac-af7f-01ff41f50bc3%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/etPan.53d2157c.4b588f54.13e40%40MacBook-Air-de-David.local.
For more options, visit https://groups.google.com/d/optout.


(system) #4