Define analyzer globally

Hi,

I'm using version 0.90.0.

I need/want to define my custom analyzers globally. therefore I edited the
configuration file of ES (elasticsearch.yml) according to this answer: Can
I customize Elastic Search to use my own Stop Word list?http://stackoverflow.com/questions/4927629/can-i-customize-elastic-search-to-use-my-own-stop-word-list/13012458#13012458the relevant entries are

index.analysis.analyzer.angram:
type: custom
tokenizer: standard
filter: standard, lowercase, fngram
index.analysis.filter.fngram:
type: nGram
min_gram: 2
max_gram: 10

but when I try to invoke curl -XGET
'localhost:9200/_analyze?analyzer=angram' -d 'this is a test' I get an ElasticSearchIllegalARgumentException[failed
to find analyzer [angram]].

is the configuration wrong? (although I'd expect ES to not start-up when
encountered an error when reading the configuration during start-up)

how do I correctly define an analyzer globally?

Thanks for your time.

BR, dp
PS: I asked the question @ stackoverflow as well
(http://stackoverflow.com/questions/16913073/define-analyzer-globally-es)
PPS: I found that viewing of all settings is not yet possible (but an issue
was created here: https://github.com/elasticsearch/elasticsearch/issues/2738https://github.com/elasticsearch/elasticsearch/issues/2738 )
which would be nice to double-check.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

You cannot use a custom analyzer until it is referenced by an index. You
would need to create a mapping that uses the analyzer and then use that
index in the analyzer call. There is no need to index any documents to that
index.

curl -XGET 'localhost:9200/SOMEINDEX/_analyze?analyzer=angram'

--
Ivan

On Wed, Jun 5, 2013 at 9:20 AM, dp.desoma@gmail.com wrote:

Hi,

I'm using version 0.90.0.

I need/want to define my custom analyzers globally. therefore I edited the
configuration file of ES (elasticsearch.yml) according to this answer: Can
I customize Elastic Search to use my own Stop Word list?http://stackoverflow.com/questions/4927629/can-i-customize-elastic-search-to-use-my-own-stop-word-list/13012458#13012458the relevant entries are

index.analysis.analyzer.angram:
type: custom
tokenizer: standard
filter: standard, lowercase, fngram
index.analysis.filter.fngram:
type: nGram
min_gram: 2
max_gram: 10

but when I try to invoke curl -XGET
'localhost:9200/_analyze?analyzer=angram' -d 'this is a test' I get an ElasticSearchIllegalARgumentException[failed
to find analyzer [angram]].

is the configuration wrong? (although I'd expect ES to not start-up when
encountered an error when reading the configuration during start-up)

how do I correctly define an analyzer globally?

Thanks for your time.

BR, dp
PS: I asked the question @ stackoverflow as well (
http://stackoverflow.com/questions/16913073/define-analyzer-globally-es)
PPS: I found that viewing of all settings is not yet possible (but an
issue was created here: h
ttps://github.com/elasticsearch/elasticsearch/issues/2738https://github.com/elasticsearch/elasticsearch/issues/2738 )
which would be nice to double-check.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Thank you!

On Wednesday, June 5, 2013 6:24:06 PM UTC+2, Ivan Brusic wrote:

You cannot use a custom analyzer until it is referenced by an index. You
would need to create a mapping that uses the analyzer and then use that
index in the analyzer call. There is no need to index any documents to that
index.

curl -XGET 'localhost:9200/SOMEINDEX/_analyze?analyzer=angram'

--
Ivan

On Wed, Jun 5, 2013 at 9:20 AM, <dp.d...@gmail.com <javascript:>> wrote:

Hi,

I'm using version 0.90.0.

I need/want to define my custom analyzers globally. therefore I edited
the configuration file of ES (elasticsearch.yml) according to this answer: Can
I customize Elastic Search to use my own Stop Word list?http://stackoverflow.com/questions/4927629/can-i-customize-elastic-search-to-use-my-own-stop-word-list/13012458#13012458the relevant entries are

index.analysis.analyzer.angram:
type: custom
tokenizer: standard
filter: standard, lowercase, fngram
index.analysis.filter.fngram:
type: nGram
min_gram: 2
max_gram: 10

but when I try to invoke curl -XGET
'localhost:9200/_analyze?analyzer=angram' -d 'this is a test' I get an ElasticSearchIllegalARgumentException[failed
to find analyzer [angram]].

is the configuration wrong? (although I'd expect ES to not start-up when
encountered an error when reading the configuration during start-up)

how do I correctly define an analyzer globally?

Thanks for your time.

BR, dp
PS: I asked the question @ stackoverflow as well (
http://stackoverflow.com/questions/16913073/define-analyzer-globally-es)
PPS: I found that viewing of all settings is not yet possible (but an
issue was created here: h
ttps://github.com/elasticsearch/elasticsearch/issues/2738https://github.com/elasticsearch/elasticsearch/issues/2738 )
which would be nice to double-check.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.