Dépendances maven & tests unitaires


(Blured Derulb) #1

Bonjour,

Afin d'utiliser les Tests unitaires spécifiques pour ELS, que faut il utiliser comme version pour randomizedtesting et org.apache.lucene ?

Pour l'instant j'ai ça

<dependency>
                    <groupId>com.carrotsearch.randomizedtesting</groupId>
                    <artifactId>randomizedtesting-runner</artifactId>
                    <version>2.1.10</version>
                    <scope>test</scope>
                  </dependency>
                  <dependency>
                    <groupId>org.apache.lucene</groupId>
                    <artifactId>lucene-test-framework</artifactId>
                    <version>4.10.4</version>
                    <scope>test</scope>
                <exclusions>
                    <exclusion>
                        <artifactId>randomizedtesting-runner</artifactId>
                        <groupId>
                            com.carrotsearch.randomizedtesting
                        </groupId>
                    </exclusion>
                </exclusions>
                  </dependency>
                  <dependency>
                    <groupId>org.elasticsearch</groupId>
                    <artifactId>elasticsearch</artifactId>
                    <version>1.6.0</version>
                    <scope>test</scope>
                    <type>test-jar</type>
                  </dependency>
                  <dependency>
                    <groupId>org.elasticsearch</groupId>
                    <artifactId>elasticsearch</artifactId>
                    <version>1.6.0</version>
                    <scope>test</scope>
                  </dependency>
        </dependencies>

Est-ce que c'est ok pour une conf avec la 1.6 ?

A+,
blured.


(system) #2