Deprecation Notice: Hadoop 1.x and ES-YARN


(James Baiera) #1

This notice is to inform the community that the following features are deprecated in 5.5.0 and will be removed in 6.0:

  1. We will no longer be testing or developing against Hadoop 1.x versions. As of 6.0 those versions will be untested and unsupported. Use them at your own risk.
  2. The Elasticsearch on Apache YARN Beta

If there are any questions or concerns over these deprecations, please feel free to discuss them on these forums.

Edit: Previously this post mentioned deprecations of the "old" mapred api. Those deprecations are erroneous. We will continue to support the "old" mapred api for as long as it is a stable component of Hadoop.


(James Baiera) #2

(James Baiera) #3

(James Baiera) #4