Disable compound file storage format


(Hanish Bansal) #1

Hi All,

I am upgrading my elastic-search from elasticsearch-0.90.0.RC2 to
elasticsearch-0.90.5.

As default file compound format is false so files should be stored as
normal files like .fdx,.fdt and many other formats. This is expected
behaviour which i was getting in elasticsearch-0.90.0.RC2.

But elasticsearch-0.90.5 storing the data as compound format.
I tried to disable compound file storage by defining "index.compound_format:
false
" in config file but it is giving the same behaviour.
When i set "index.refresh_interval: 1" in config file then it started
storing the data as normal. After restarting elastic-search it again
convert the data as compound format.

Any suggestion how to disable compound file storage format ?

--
Thanks & Regards
Hanish Bansal

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Martijn Van Groningen) #2

Newly flushed segments are will be written into the compound format regards
less of the compound_format setting. This setting applies on when
segments get merged into bigger segments. In general means that only small
segments will have the compound file format.

What is the reason why you don't want compound segments? The idea behind
compound file format is to reduce the number of open file descriptors to a
Lucene index (shard). Since segments get flushed all the time due to
frequent refresh (1 second by default), there can be some compound segments.

On 30 September 2013 09:28, Hanish Bansal
hanish.bansal.agarwal@gmail.comwrote:

Hi All,

I am upgrading my elastic-search from elasticsearch-0.90.0.RC2 to
elasticsearch-0.90.5.

As default file compound format is false so files should be stored as
normal files like .fdx,.fdt and many other formats. This is expected
behaviour which i was getting in elasticsearch-0.90.0.RC2.

But elasticsearch-0.90.5 storing the data as compound format.
I tried to disable compound file storage by defining "index.compound_format:
false
" in config file but it is giving the same behaviour.
When i set "index.refresh_interval: 1" in config file then it started
storing the data as normal. After restarting elastic-search it again
convert the data as compound format.

Any suggestion how to disable compound file storage format ?

--
Thanks & Regards
Hanish Bansal

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
Met vriendelijke groet,

Martijn van Groningen

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Igor Masternoy) #3

I think you can use these two properties:
index:
compound_format: false
compound_on_flush: false

As the result you will get 6 files for newly created segments. Without these properties it would be 2 files: segname.scf and segname.si.

P.S. 2 years have been passed :wink:


(system) closed #4