Disable login in Kibana 5.3


(Pablo) #1

Hi,

I have configured ELK with X-Pack and enabled the anonymous authentication. This allows me to access to Elasticsearch API without any issue, but when accessing through Kibana is asking for credentials, even giving the anonymous user kibana or superuser role.

I have seen this thread and I think it's related but just wanted to confirm if I need to create a new issue.

Kind regards,
Pablo


Native authentication showing up even if it is disabled
XPACK Custom Realm with SSO integration
Login in Kibana using Custom Realm installed in Elasticsearch
(Stacey Gammon) #2

You can turn off security entirely, which will disable the login screen, by setting
xpack.security.enabled: false in elasticsearch.yml and kibana.yml, but that may not be what need.

Is your goal to have users be automatically logged in with a certain role (say, read only?)?

The latter can be done with a reverse proxy. There is some good info on this here:

As for the anonymous authentication, I'm not sure how kibana is supposed to act when that is set up in elasticsearch, but I'll try to find out more information.


(Pablo) #3

Awesome stuff Stacy, I think it's just what I need, I have an nginx behind Kibana, so I'll give it a try tomorrow.
Thank you very much


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.