Disable memory swapping


#1

I am using Docker Toolbox in Windows 8.1 environment. I am new to docker. I am trying to install an open source app which call for installing elasticsearch. I have never use elasticsearch before.
The first instruction installing that app is to disable swapping. In its instruction, it said:

$ sudo sysctl -w vm.swappiness=1
$ echo 'vm.swappiness=1' >> /etc/sysctl.conf (to persist reboots)

I am in windows host environment. The above instruction is for Linux host environment.
Disabling swapping in windows environment (by default, swapping is enabled) is very bad.
Must I stop swapping in my windows host in order to run an app in Docker (guest) which requires the installation of Elasticsearch?
Can I do this swap disabling inside Docker (prior to installing the app) instead?
If yes, how to do it?

Thanks in advance.


(system) #2

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.