Disable norms for AttachmentPlugin


(Stefan Beigel) #1

Hi guys,

iam using the elasticsearch-mapper-attachments plugin with version 3.1.
I just want to know if it is possible to use the norm property with the attachment plugin.

i tried this:

{  
    "test":{  
        "properties":{  
            "file":{  
                "type":"attachment",
                "norms":{  
                    "enabled":false
                }
            }
        }
    }
}

But i got Mapping definition for [file] has unsupported parameters: [norms : {enabled=false}]
Maybe someone knows how to handle this.

greets
Stefan


(David Pilato) #2

Not on the attachment field itself but probably on the sub fields which are generated at index time.


(Stefan Beigel) #3

Do you mean something like this:

"test":{  
    "test":{  
        "properties":{  
            "file":{  
                "type":"attachment",
                "fields":{  
                    "content":{  
                        "type":"string",
                        "norms":{  
                            "enabled":false
                        }
                    }
                }
            }
        }
    }
}

This does not work for me.
Am I doing something wrong?


(David Pilato) #4

Yes. Do you get an error when doing that?


(Stefan Beigel) #5

No iam getting no error.
But it does not have any effect.
I guess I should see the result with a GET on _mapping.
But the field content does not have the property norms.


(David Pilato) #6

Can you open an issue with a full recreation script so we can look if it's a bug or something we actually can't support with this plugin?

Thanks!


(system) #7