Display UTC on Timeseries axis


(Jerry Robinson) #1

I want to display UTC time everywhere. Using Management:Advanced Setttings: dateFormat:tz set to UTC I can get UTC time displayed on the discover page. On my dashboard, for example a timeseries visualization, on the x-axis the time is still displayed as local time. How do I get the x-axis of the timeseries to display time in UTC?

FYI: Hovering over the axis shows UTC time but the printed axis time is localtime. I investigated dateFormat under advanced settings without luck.


(Jon Budzenski) #2

It sounds like a bug, the chart should respect timezone settings. Can you share which visualization builder you used, and what your Kibana version is? Are you using a date histogram on the x axis?


(Jerry Robinson) #3

Jon,

thanks for your response.

Kibana version 6.1.2

Visual Builder, I don’t see a builder version but it is marked as experimental (version should be recent as of the ~ last 6 months, I didn’t install it).

This was a time series visualization.

Data: Metrics Aggregation: count Group By: Everything

Panel options: Time Field: kb_time (@timestamp didn’t help), interval: auto

Snapshot showing UTC for hover but axis is not respecting UTC.


(Jon Budzenski) #4

Ah, it does appear to be a bug - fixed in 6.2.0.

https://github.com/elastic/kibana/pull/15512. If upgrading isn't an option we could use a different visualization builder like the line chart.


(Jerry Robinson) #5

Jon, thank you.

I’ll try the upgrade path


(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.