Docker Elasticsearch failing

Hi Team,

I have created a 3 node elasticsearch setup. One of my docker container fails with the below error

lasticsearch/config/roles.yml]" }
{"type": "server", "timestamp": "2020-09-06T20:23:28,362Z", "level": "INFO", "component": "o.e.d.DiscoveryModule", "cluster.name": "docker-cluster", "node.name": "githublogging1", "message": "using discovery type [zen] and seed hosts providers [settings]" }
{"type": "server", "timestamp": "2020-09-06T20:23:28,755Z", "level": "WARN", "component": "o.e.g.DanglingIndicesState", "cluster.name": "docker-cluster", "node.name": "githublogging1", "message": "gateway.auto_import_dangling_indices is disabled, dangling indices will not be automatically detected or imported and must be managed manually" }
{"type": "server", "timestamp": "2020-09-06T20:23:29,130Z", "level": "INFO", "component": "o.e.n.Node", "cluster.name": "docker-cluster", "node.name": "githublogging1", "message": "initialized" }
{"type": "server", "timestamp": "2020-09-06T20:23:29,131Z", "level": "INFO", "component": "o.e.n.Node", "cluster.name": "docker-cluster", "node.name": "githublogging1", "message": "starting ..." }
{"type": "server", "timestamp": "2020-09-06T20:23:29,249Z", "level": "INFO", "component": "o.e.t.TransportService", "cluster.name": "docker-cluster", "node.name": "githublogging1", "message": "publish_address {10.0.0.193:9300}, bound_addresses {0.0.0.0:9300}" }
{"type": "server", "timestamp": "2020-09-06T20:23:29,388Z", "level": "INFO", "component": "o.e.b.BootstrapChecks", "cluster.name": "docker-cluster", "node.name": "githublogging1", "message": "bound or publishing to a non-loopback address, enforcing bootstrap checks" }
ERROR: [1] bootstrap checks failed
[1]: initial heap size [2136997888] not equal to maximum heap size [2147483648]; this can cause resize pauses
ERROR: Elasticsearch did not exit normally - check the logs at /usr/share/elasticsearch/logs/docker-cluster.log
{"type": "server", "timestamp": "2020-09-06T20:23:29,395Z", "level": "INFO", "component": "o.e.n.Node", "cluster.name": "docker-cluster", "node.name": "githublogging1", "message": "stopping ..." }
{"type": "server", "timestamp": "2020-09-06T20:23:29,405Z", "level": "INFO", "component": "o.e.n.Node", "cluster.name": "docker-cluster", "node.name": "githublogging1", "message": "stopped" }
{"type": "server", "timestamp": "2020-09-06T20:23:29,405Z", "level": "INFO", "component": "o.e.n.Node", "cluster.name": "docker-cluster", "node.name": "githublogging1", "message": "closing ..." }
{"type": "server", "timestamp": "2020-09-06T20:23:29,416Z", "level": "INFO", "component": "o.e.n.Node", "cluster.name": "docker-cluster", "node.name": "githublogging1", "message": "closed" }
{"type": "server", "timestamp": "2020-09-06T20:23:29,417Z", "level": "INFO", "component": "o.e.x.m.p.NativeController", "cluster.name": "docker-cluster", "node.name": "githublogging1", "message": "Native controller process has stopped - no new native processes can be started" }

Please help me understand the reason.

Regards
TJ

Hi @tamilarasanbravo

It usually helps to post your config files / docker compose etc..

The error seems to indicate that the JVM heap settings are not equal.

https://www.elastic.co/guide/en/elasticsearch/reference/current/heap-size.html

Elasticsearch will assign the entire heap specified in jvm.options via the Xms (minimum heap size) and Xmx (maximum heap size) settings. You should set these two settings to be equal to each other.