(Docker) how to run ES on a docker hoster?


(thinking23487) #1

Hi all,

i'm trying to run ES on a docker hosting service provider and have the problem that the container doesnt start cause of bootstrap checks:
[2017-02-03T13:10:31,019][INFO ][o.e.t.TransportService ] [dkejAzL] publish_address {172.17.0.2:9300}, bound_addresses {[::]:9300}
[2017-02-03T13:10:31,030][INFO ][o.e.b.BootstrapChecks ] [dkejAzL] bound or publishing to a non-loopback or non-link-local address, enforcing bootstrap checks
ERROR: bootstrap checks failed
max virtual memory areas vm.max_map_count [65530] is too low, increase to at least [262144]

A few days ago it seems this has been solved, but i dont get it running.
This issue states that the container should run anywhere without problems by running locally on my dev box:
docker run -d --name elas elasticsearch -Etransport.host=0.0.0.0 -Ediscovery.zen.minimum_master_nodes=1

I got the same problem as the docker hoster, the boostrap checks fail and i cannot change vm.max_map_count cause i dont have access to the host where the container will run.
Did i do anything wrong? The issue mentioned that it has been solved, but i dont get it running. Any hints on the next step to try?

thx


(Tanguy) #2

Hi,

Did you try the official docker image by Elastic https://github.com/elastic/elasticsearch-docker?


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.