Document count and includes_action_and_meta_data


(sharath) #1

I have a custom rally track where I am bulk indexing data. My data is in the

action_and_meta_data\n
source\n

format, which means that I have 2 lines for each document. My types have 'includes_action_and_meta_data' set to true. Now if I set my 'document-count' to have the number of documents (which is the number of lines/2), rally throws an error saying the counts don't match. If I set the doc count as the number of lines, I see that that the action_and_meta_data also gets indexed as a document.

Is there a setting I am missing ?


(Daniel Mitterdorfer) #2

Hi @sharathr83,

sorry to hear this. This is an error in the documentation. The correct name of the setting is includes-action-and-meta-data (note the hyphens instead of underscores).

Can you please correct the setting, delete ~/.rally/benchmarks/data/YOUR_TRACK_NAME/*.json.offset and retry?

Daniel


(sharath) #3

yes, that worked. Thanks !


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.