Document getting lost


(venkata nagaraju buddarapu) #1

Hi ,

Document getting lost due to queue size settings and also see ESRejection
exception as explained in below article

https://www.loggly.com/blog/nine-tips-configuring-elasticsearch-for-high-performance/

I want to understand that if right queue size is set then there is no
chance of document /data loss or is there any parameter I need to configure
?

Regards,
Nagaraju

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/ba6b8d3a-71a2-41f1-b489-58d7938e9f48%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Mark Walkom) #2

Simply increasing the depths means more things will queue, but you still
need to catch up on that queue. If you are overloaded then this will never
happen and your queue won't be much help.
Look at the larger picture, are you running out of resources consistently
or is it transitory?

On 22 April 2015 at 14:08, bvnrwork budda08nitt@gmail.com wrote:

Hi ,

Document getting lost due to queue size settings and also see ESRejection
exception as explained in below article

https://www.loggly.com/blog/nine-tips-configuring-elasticsearch-for-high-performance/

I want to understand that if right queue size is set then there is no
chance of document /data loss or is there any parameter I need to configure
?

Regards,
Nagaraju

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/ba6b8d3a-71a2-41f1-b489-58d7938e9f48%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/ba6b8d3a-71a2-41f1-b489-58d7938e9f48%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEYi1X-qcs7PPQwCE96T_LPVE77qjUAAX8jzuyvzOe38mcKW6w%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(venkata nagaraju buddarapu) #3

No we have good enough resource , only 20 % resources are utilized

On Wednesday, 22 April 2015 00:45:24 UTC-4, Mark Walkom wrote:

Simply increasing the depths means more things will queue, but you still
need to catch up on that queue. If you are overloaded then this will never
happen and your queue won't be much help.
Look at the larger picture, are you running out of resources consistently
or is it transitory?

On 22 April 2015 at 14:08, bvnrwork <budda...@gmail.com <javascript:>>
wrote:

Hi ,

Document getting lost due to queue size settings and also see ESRejection
exception as explained in below article

https://www.loggly.com/blog/nine-tips-configuring-elasticsearch-for-high-performance/

I want to understand that if right queue size is set then there is no
chance of document /data loss or is there any parameter I need to configure
?

Regards,
Nagaraju

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/ba6b8d3a-71a2-41f1-b489-58d7938e9f48%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/ba6b8d3a-71a2-41f1-b489-58d7938e9f48%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/e3725c26-6509-4683-b6ea-0c2f60bce11e%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #4