Does anyone know about unique identifiers for synthetic multipage journey?

Hi Team,

I have a deployment in elastic cloud where I need to create multi page synthetic journey but as the web application is deployed in AWS, we have cloudflare which is blocking unwanted requests and it is blocking the synthetics journey also. May I know if it has any unique identifiers which can identify this request or any other way to complete the journey?

Note: I was trying to access public domain only.

Hi @surya_dadi_dhamarake,

Just a heads up that I've changed the topic of your question to Synthetics to ensure it's picked up correctly.

1 Like

Hello, @surya_dadi_dhamarake we append string Elastic/Synthetics to user agent , maybe you can use that to unblock
Example being.

Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) HeadlessChrome/117.0.5938.62 Safari/537.36 Elastic/Synthetics

I hope this help.

1 Like

If you are looking to whitelist Elastic IP addresses which are used in Synthetics service, that is documented here Use Synthetics with traffic filters | Elastic Observability [8.11] | Elastic

1 Like

Hi @shahzad31 ,

Are those IP addresses unique per deployment and static? if those are public IP addresses which may allocate to other org also, then we cannot use whitelisting IP addresses or ranges. Can you please confirm? I will check on the ELastic/Synthetics string at the end of the request.


They are shared with other users. You could set a custom header for your tests however by setting the extraHTTPHeaders playwright option in your synthetics.config.ts. It looks like this:

export default env => {
  const config: SyntheticsConfig = {
    playwrightOptions: {
      extraHTTPHeaders: {
         // use whichever headers would work for your setup
        "X-My-Header": "My-Value"
   // rest of your config...

Hi @Andrew_Cholakian1 ,

Where can I give those headers? I cannot find synthetics.config.ts option in kibana. Can you please give me the steps to add this config for elastic cloud deployment?

I am only seeing below option in kibana.


Hi @surya_dadi_dhamarake,

Per @Andrew_Cholakian1's steps the headers can be specified in the Playwright options section that you have in your screenshot.

Hope that helps!

1 Like

So that means, I should only add this block in the playwright options.

1 Like

Thanks @carly.richmond & @Andrew_Cholakian1 , That works. I can see my custom headers in the request.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.