Does elasticsearh-curator 3.0.3 support elasticsearch 1.0.1


(sumeet dembra) #1

Hi,

I am getting some error while running curator snapshot command.

curator version: 3.0.3
ES version: 1.0.1
Following is how my command looks:
curator --port 9201 snapshot --repository test_repo indices --newer-than
1 --time-unit days --index 'logstash-2015.05.02' --timestring %Y.%m.%d

Following is the error:
2015-05-05 15:34:10,627 WARNING Overriding default connection timeout.
New timeo ut: 21600
2015-05-05 15:34:11,052 ERROR Could not extract a timestamp matching
2014.00.28 from timestring %Y.%m.%d

Somewhere I read curator 3 does not support 1.0.1. Can anyone please
confirm?
If it does not support, then what is the solution?

Thanks in advance.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/668c4e80-79f1-4654-bb69-291d4bf23da8%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Mark Walkom) #2

2014.00.28 is not a valid date, where is that coming from?

On 5 May 2015 at 20:09, sumeet dembra sumeetdembra@gmail.com wrote:

Hi,

I am getting some error while running curator snapshot command.

curator version: 3.0.3
ES version: 1.0.1
Following is how my command looks:
curator --port 9201 snapshot --repository test_repo indices
--newer-than 1 --time-unit days --index 'logstash-2015.05.02' --timestring
%Y.%m.%d

Following is the error:
2015-05-05 15:34:10,627 WARNING Overriding default connection timeout.
New timeo ut: 21600
2015-05-05 15:34:11,052 ERROR Could not extract a timestamp matching
2014.00.28 from timestring %Y.%m.%d

Somewhere I read curator 3 does not support 1.0.1. Can anyone please
confirm?
If it does not support, then what is the solution?

Thanks in advance.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/668c4e80-79f1-4654-bb69-291d4bf23da8%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/668c4e80-79f1-4654-bb69-291d4bf23da8%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
Please update your bookmarks! We moved to https://discuss.elastic.co/

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEYi1X9gUx1eLLw%3DV3xrQCKY6tVFZkhyqEnJCaqChmd3wuBkhg%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(sumeet dembra) #3

That is what I am not getting.
Why is it showing 2014.00.28?
There is no such index present in
my ES setup which has date
2014.00.28..

On Wed, May 6, 2015 at 3:55 AM, Mark Walkom markwalkom@gmail.com wrote:

2014.00.28 is not a valid date, where is that coming from?

On 5 May 2015 at 20:09, sumeet dembra sumeetdembra@gmail.com wrote:

Hi,

I am getting some error while running curator snapshot command.

curator version: 3.0.3
ES version: 1.0.1
Following is how my command looks:
curator --port 9201 snapshot --repository test_repo indices
--newer-than 1 --time-unit days --index 'logstash-2015.05.02' --timestring
%Y.%m.%d

Following is the error:
2015-05-05 15:34:10,627 WARNING Overriding default connection timeout.
New timeo ut: 21600
2015-05-05 15:34:11,052 ERROR Could not extract a timestamp matching
2014.00.28 from timestring %Y.%m.%d

Somewhere I read curator 3 does not support 1.0.1. Can anyone please
confirm?
If it does not support, then what is the solution?

Thanks in advance.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/668c4e80-79f1-4654-bb69-291d4bf23da8%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/668c4e80-79f1-4654-bb69-291d4bf23da8%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
Please update your bookmarks! We moved to https://discuss.elastic.co/

You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/HtYdcRJItGs/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAEYi1X9gUx1eLLw%3DV3xrQCKY6tVFZkhyqEnJCaqChmd3wuBkhg%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CAEYi1X9gUx1eLLw%3DV3xrQCKY6tVFZkhyqEnJCaqChmd3wuBkhg%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
Please update your bookmarks! We moved to https://discuss.elastic.co/

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAF0ca0jGK2vEnjGXyqWUN2r37V26oqNgOb4eiY9Na9qPof-5dw%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Magnus Bäck) #4

On Wednesday, May 06, 2015 at 07:09 CEST,
sumeet dembra sumeetdembra@gmail.com wrote:

That is what I am not getting.
Why is it showing 2014.00.28?
There is no such index present inÂ
my ES setup which has dateÂ
2014.00.28..

Looking at the code I suspect you have a snapshot or an index with that
name. The exception happens in timestamp_check[0] which is only called
from apply_filter[1]. apply_filter is, in turn, called from [2] and [3].
Upping the loglevel to 'debug' will cause the list being filtered to be
logged.

[0] https://github.com/elastic/curator/blob/v3.0.3/curator/api/filter.py#L285
[1] https://github.com/elastic/curator/blob/v3.0.3/curator/api/filter.py#L127
[2] https://github.com/elastic/curator/blob/v3.0.3/curator/cli/snapshot_selection.py#L74
[3] https://github.com/elastic/curator/blob/v3.0.3/curator/cli/index_selection.py#L80

--
Magnus Bäck | Software Engineer, Development Tools
magnus.back@sonymobile.com | Sony Mobile Communications

--
Please update your bookmarks! We moved to https://discuss.elastic.co/

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/20150506074757.GA16989%40seldlx20533.corpusers.net.
For more options, visit https://groups.google.com/d/optout.


(system) #5