Dot not used as delimiter

Hi,

I just find out that if texte is something like 'computer.rails' , search
on "computer" will not find this text. If I change to 'computer.
rails' (with space after dot), then it is working
I saw her some info, but couldnt understand :
http://www.elasticsearch.org/guide/reference/index-modules/analysis/word-delimiter-tokenfilter/

can anyone help me ?

thanks

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

You're probably using Standard analyzer which recognises hostnames.

$ curl -X GET "http://localhost:9200/_analyze?analyzer=standard&pretty=true"
-d
"computer.rails"

{
"tokens" : [ {
"token" : "computer.rails",
"start_offset" : 0,
"end_offset" : 14,
"type" : "",
"position" : 1
} ]
}

The giving of space works because,

$ curl -X GET "http://localhost:9200/_analyze?analyzer=standard&pretty=true"
-d "computer. rails"
{
"tokens" : [ {
"token" : "computer",
"start_offset" : 0,
"end_offset" : 8,
"type" : "",
"position" : 1
}, {
"token" : "rails",
"start_offset" : 10,
"end_offset" : 15,
"type" : "",
"position" : 2
} ]
}

Depending on your needs, you might want to use a different analyzer like
simple
http://www.elasticsearch.org/guide/reference/index-modules/analysis/simple-analyzer/

On Wed, Jun 19, 2013 at 1:02 AM, oto iashvili
optimum.dulopin@laposte.netwrote:

Hi,

I just find out that if texte is something like 'computer.rails' , search
on "computer" will not find this text. If I change to 'computer.
rails' (with space after dot), then it is working
I saw her some info, but couldnt understand :

http://www.elasticsearch.org/guide/reference/index-modules/analysis/word-delimiter-tokenfilter/

can anyone help me ?

thanks

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
Regards,
Abhijeet Rastogi (shadyabhi)

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

hi,

thanks for answer

actually computer.rails what just as example. My text are mainly georgian,
so texts are like "მეტლახი.ჩასაშენებელი"
Does simple analyzer will also work with this kind of letters ?
Does it recognize singular and pluriel for georgian and all different
endings for words ?

thanks again

On Tuesday, June 18, 2013 10:01:53 PM UTC+2, Abhijeet Rastogi wrote:

You're probably using Standard analyzer which recognises hostnames.

$ curl -X GET "
http://localhost:9200/_analyze?analyzer=standard&pretty=true" -d
"computer.rails"

{
"tokens" : [ {
"token" : "computer.rails",
"start_offset" : 0,
"end_offset" : 14,
"type" : "",
"position" : 1
} ]
}

The giving of space works because,

$ curl -X GET "
http://localhost:9200/_analyze?analyzer=standard&pretty=true" -d
"computer. rails"
{
"tokens" : [ {
"token" : "computer",
"start_offset" : 0,
"end_offset" : 8,
"type" : "",
"position" : 1
}, {
"token" : "rails",
"start_offset" : 10,
"end_offset" : 15,
"type" : "",
"position" : 2
} ]
}

Depending on your needs, you might want to use a different analyzer like
simple
http://www.elasticsearch.org/guide/reference/index-modules/analysis/simple-analyzer/

On Wed, Jun 19, 2013 at 1:02 AM, oto iashvili <optimum...@laposte.net<javascript:>

wrote:

Hi,

I just find out that if texte is something like 'computer.rails' ,
search on "computer" will not find this text. If I change to 'computer.
rails' (with space after dot), then it is working
I saw her some info, but couldnt understand :

http://www.elasticsearch.org/guide/reference/index-modules/analysis/word-delimiter-tokenfilter/

can anyone help me ?

thanks

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
Regards,
Abhijeet Rastogi (shadyabhi)
http://blog.abhijeetr.com

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

There is no Georgian language analyzers as far as I can tell in
Lucene/elasticsearch. Your best bet is to experiment with the Analysis API
using different analyzers.

http://www.elasticsearch.org/guide/reference/api/admin-indices-analyze/

--
Ivan

On Tue, Jun 18, 2013 at 6:10 PM, oto iashvili
optimum.dulopin@laposte.netwrote:

hi,

thanks for answer

actually computer.rails what just as example. My text are mainly georgian,
so texts are like "მეტლახი.ჩასაშენებელი"
Does simple analyzer will also work with this kind of letters ?
Does it recognize singular and pluriel for georgian and all different
endings for words ?

thanks again

On Tuesday, June 18, 2013 10:01:53 PM UTC+2, Abhijeet Rastogi wrote:

You're probably using Standard analyzer which recognises hostnames.

$ curl -X GET "http://localhost:9200/_analyze?analyzer=standard&
pretty=truehttp://localhost:9200/_analyze?analyzer=standard&pretty=true"
-d "computer.rails" ** **

{
"tokens" : [ {
"token" : "computer.rails",
"start_offset" : 0,
"end_offset" : 14,
"type" : "",
"position" : 1
} ]
}

The giving of space works because,

$ curl -X GET "http://localhost:9200/_analyze?analyzer=standard&
pretty=truehttp://localhost:9200/_analyze?analyzer=standard&pretty=true"
-d "computer. rails"
{
"tokens" : [ {
"token" : "computer",
"start_offset" : 0,
"end_offset" : 8,
"type" : "",
"position" : 1
}, {
"token" : "rails",
"start_offset" : 10,
"end_offset" : 15,
"type" : "",
"position" : 2
} ]
}

Depending on your needs, you might want to use a different analyzer like
simple http://www.elasticsearch.org/guide/reference/index-modules/
analysis/simple-analyzer/http://www.elasticsearch.org/guide/reference/index-modules/analysis/simple-analyzer/

On Wed, Jun 19, 2013 at 1:02 AM, oto iashvili optimum...@laposte.netwrote:

Hi,

I just find out that if texte is something like 'computer.rails' ,
search on "computer" will not find this text. If I change to 'computer.
rails' (with space after dot), then it is working
I saw her some info, but couldnt understand :
http://www.elasticsearch.org/guide/reference/index-modules/
analysis/word-delimiter-**tokenfilter/http://www.elasticsearch.org/guide/reference/index-modules/analysis/word-delimiter-tokenfilter/

can anyone help me ?

thanks

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@**googlegroups.com.

For more options, visit https://groups.google.com/**groups/opt_outhttps://groups.google.com/groups/opt_out
.

--
Regards,
Abhijeet Rastogi (shadyabhi)
http://blog.abhijeetr.com

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.