Drop_fields or include_fields dosn't worsk

hello,

I want to suppress some fields I doesn't use from and event.
Neither processor, Nor filters works I don't Know what is the matter I looked for other issue close from that but did'nt find solution.
When I use Processor or filter, metricbeat send nothing to elasticsearch but when I remove , every fields are sent

Here is my configuration file : system.yml

HI,

First off, you should not post images, people use all sorts of devices and on most of them they very small and hard to read. You could copy & paste the info and use the < /> tag to format it properly.

Reading you image it syntax looks different then the docs specify. Have a read here, maybe it helps.

Regards,
Paul.

Hi,

Thank you for your answer.
Actually I've tried every configuration in docs but no results.
When I add processors or filter , No data is sent to Elasticsearch.
The only enabled module is system.

Regards

#==========================  Modules configuration ============================  
metricbeat.config.modules:
  path: ${path.config}/modules.d/*.yml
  reload.enabled: true

fields:
  service: metricbeat

cpu.metrics:  ["percentages"]
core.metrics: ["percentages"]

processors:
 - drop_fields:
     when:
        equals:
          metricset.name: "cpu"
     fields: ["system.cpu.steal.pct", "system.cpu.irq.pct", "system.cpu.iowait.pct"]
     ignore_missing: false

output.logstash:
  hosts: ["127.0.0.1:5043"]

I removed the ignore missing clause and it works !

1 Like