Metricbeat does not create fields in document


I am having metricbeat configured with system module and enabled but the it does not create the fields in the elasticsearch documents. However creating the vizualization does show the graphs.

- module: system
    - cpu             # CPU usage
    - filesystem      # File system usage for each mountpoint
    - fsstat          # File system summary metrics
    - load            # CPU load averages
    - memory          # Memory usage
    - network         # Network IO
    - process         # Per process metrics
    - process_summary # Process summary
    - uptime          # System Uptime
    - core           # Per CPU core usage
    - diskio         # Disk IO
    - socket         # Sockets and connection info (linux only)
  enabled: true
  period: 10s
  processes: ['.*']

  cpu.metrics:  ["percentages"]  # The other available options are normalized_percentages and ticks.
  core.metrics: ["percentages"]  # The other available option is ticks.

  process.cmdline.cache.enabled: true

  process.cgroups.enabled: true

but in Kibana it only shows up if I disable the checkbox for disabling missing fields:

Any idea how to fix this?

Not sure I fully understand this. The metricbeat data is sent correctly to Elasticsearch contain all documents with all fields. Then you want to filter on a field but it does not show up in Kibana? If yes, is that the case for all fields or a specific one?

  • Which version of KB are you using?
  • How did you create the index pattern?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.