Metricbeat and availables metrics


(Matt Dee) #1

HI, I just installed metricbeat and I see that there are about 326 fields available for the metricbeat indexes on the kibana dashboard.

I'm only seeing 71 fields that are being populated.

I'm particulary interested in(but they're not being populated):
system.process.cpu.system
system.process.cpu.user

I'm currently running centos 7.1.1503 and metricbeat version 5.0.0-alpha5 (amd)64, libbeat 5.0.0-alpha5

My config file is as follows( I typed it in so there might be some mistypes):

metricbeat.modules:

  • module: system
    metricsets:

    • cpu
    • load
    • core
    • diskio
    • filesystem
    • fsstat
    • memory
    • network
    • process
      enabled: true
      period: 10s
      processes: ['.*']

    cpu_ticks: false

output.elasticsearch:
hosts: ["foo", "bar]


(Andrew Kroh) #2

Those fields should be present when cpu_ticks: true is configured. But there was a bug affecting the process metricset that will be fixed in the next minor release.


(Matt Dee) #3

Yeah. Tried it with cpu_ticks set to true/false on the latest version(5.4) and it didn't work.

So 5.5? Could I pull master and test with that for now?


(Andrew Kroh) #4

You can try the snapshot build from master. https://beats-nightlies.s3.amazonaws.com/index.html?prefix=metricbeat/


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.