Missing metricset data in Metricbeat


(Mark Duszyk) #1

This is my metricbeat configuration file:

metricbeat.modules:
- module: system
  metricsets:
    - cpu

    - load

    - core

    - diskio

    - filesystem

    - fsstat

    - memory

    - network

    - process

  enabled: true
  cpu_ticks: true
  cgroups: true
  period: 30s

  metricsets: ["filesystem"]
  filters:
    - drop_event.when.regexp.mount_point: '^/(sys|run|proc|dev)|(rpc_pipefs|gvfs|pts)$'
#-------------------------- Elasticsearch output ------------------------------
output.elasticsearch:
  # Array of hosts to connect to.
  hosts: ["10.18.50.198:9200"]
  template.enabled: true
  template.path: "/etc/metricbeat/metricbeat.template.json"
  template.name: "metricbeat"
  template.overwrite: true
  index: "metricbeat-%{+yyyy.MM.dd}"

In Kibana, I can only "see" file system information but need all the cpu, io, info as well. It seems that the rest of fields int this index are missing?

By the way, I just installed filebeat on one of my hosts and do not see its logs in Kibana - misssing fields......

Thanks
MarkD


(Andrew Kroh) #2

You have declared the metricsets array twice in the same configuration block. Only the last declaration will be honored. So remove the line metricsets: ["filesystem"].


(Mark Duszyk) #3

Andrew, it worked like a CHARM!!!
thanks you
MarkD


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.