Metricsets are ignored


#1

with the configuration below I keep getting all metricbeat fields in kibana: processes, network etc.
I would expect to have only the cpu data based on my config.
Are my expectation wrong? What is the purpose of metricsets if it doesn't disable anything.

metricbeat.modules:
- module: system
  metricsets: ["cpu"]
  #  - cpu
  #  - filesystem
  #  - memory
  #  - network
  #  - process
  enabled: true
  period: 10s
  processes: []
  cpu_ticks: false

#2

so obviously I had
metricbeat.config.modules
which I skipped as something default, that would overwrite the metricbeat.modules.
why is it included in default configuration, without even mentioning it in Getting started with Metricbeat


(Andrew Kroh) #3

I opened an issue to get the Getting Started docs updated with information about modules.d (it was a relatively new change to move the default config there). https://github.com/elastic/beats/issues/7570

You can instantiate a module more than one time with different options so it doesn't overwrite module definitions. All of the enabled modules in the main metricbeat.yml and modules.d/*.yml are collected and used.


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.