Can't disable some metricsets


(Khaled Saidi) #1

Hi everybody,

I'm running metricbeat agent v6.4.1 on a windows 7 enterprise SP1 .
I want to gather some metricsets of the System module.
So my conf is :

metricbeat.modules:
#------------------------------- System Module -------------------------------
- module: system
  metricsets:
    - cpu             # CPU usage
    - filesystem      # File system usage for each mountpoint
    - memory          # Memory usage
    - process_summary # Process summary
    - uptime          # System Uptime
    - core            # Per CPU core usage
    #- fsstat         # File system summary metrics
    #- load           # CPU load averages
    #- network        # Network IO
    #- process        # Per process metrics
    #- diskio         # Disk IO
    #- raid           # Raid
    #- socket         # Sockets and connection info (linux only)  

  enabled: true
  period: 3600s
  processes: ['.*']

  # Configure the metric types that are included by these metricsets.
  cpu.metrics:  ["percentages"]  # The other available options are normalized_percentages and ticks.
  core.metrics: ["percentages"]  # The other available option is ticks.

I restart the metricbeat service.
And on Kibana, i still have all the metricsets collected, as network, fsstat, process...

Need help to find what is wrong in my configuration file.
Thx a lot.

BR,


(Jaime Soriano) #2

Hi @Khaled_Saidi,

Please check that you are not including the system module multiple times. This can happen if you have the system module defined in the metricbeat.yml file and also in some of the files included in the modules.d directory. If that is the case, our recommendation would be to remove the module configuration for the main configuration file, and use the module-specific files.
If you prefer to use an only file, be sure to disable the configs you don't want in the modules.d directory.


(Khaled Saidi) #3

Thank you Jaime.
I forgot to disable the System module in the modules.d directory.
You're the best. thank you again.


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.