Dynamic scripting doesn't work even though I have enabled it


(Chris) #1

On my local computer, I enable dynamic scripting by adding either of these to config/elasticsearch.yml:
script.disable_dynamic: false
or
script.inline: on
script.indexed: on

and it works. However, on a development server that a colleague gave me, I did the same thing and dynamic scripting still doesn't work (Error is: QueryParsingException[[visualsearch_cuong] script_score the script could not be loaded]; nested: ScriptException[dynamic scripting for [groovy] disabled]; ). There're quite many indexes on that server (including my index) and the Elasticsearch version is 1.7.2.

I'm pretty new to Elasticsearch. What could be wrong? Thanks


(Chris) #2

I know my question is not very clear because "A lot of things could be wrong", but I honestly don't know what to search. If you need any further information from my server I'll provide. I just want to find out what potentially can cause the problem. Thanks


(nainy) #3

I don't know if you've already resolved the issue, but you need to refer to the manual here:
https://www.elastic.co/guide/en/elasticsearch/reference/current/modules-scripting.html#enable-dynamic-scripting

Basically, you need to enable groovy language for your specific need. Mine was to add:
script.engine.groovy.inline.search: off


(Chris) #4

I thought Groovy is used by default as scripting language for Elastic? I tried what you suggested but it didn't help. May be need to put to on?


(nainy) #5

Oh, yeah, sorry. Definitely on. I'm losing my mind slowly, trying to solve my own ES issues. :slight_smile:

Does it help with on?


(system) #6