ECE config SAML

Hello

I have a ECE cluster with 2 nodes (hot, warm) and with machine learning. I activated SAML configuration on one of the nodes. It actually works but not all the time.

Do I need to add the configuration in the hot and warm and also in the machine learning?

When I add it there, the configuration update fails.

Thanks a lot, best regards
Raphael

It works when Kibana hits the node with the SAML configuration, and it doesn't work when it hits the nodes without the SAML Configuration.

Yes, we suggest that you do.

How and what is the actual error message ?

The error is :
[rolling-upgrade]: [no.found.constructor.steps.waiting.ServerBootloopingException: Instance is bootlooping [ElasticsearchInstance(ElasticsearchCluster(eef384363dea4c0c990f17e80fbfa77b),instance-0000000045)]]

Le ven. 15 mai 2020 à 08:24, Ioannis Kakavas via Discuss the Elastic Stack elastic@discoursemail.com a écrit :

I can only assume that the settings you copy over are not correct or are not the same for all the nodes. The logs of the node that is bootlooping would have more information about why it is bootlooping I think. Maybe a good opportunity to get your support engineer involved to get to the bottom of this !

Hi,

I finally found out what was wrong. I didn't had the "user_bundle" section in all Elasticsearch sections in the "Advanced settings".
Once done, the setting were applied successfully.

Thanks