ECK 1.0.0-beta1 doesn't start pod

Hi,

I'm beginning to use ECK, I deploy it on my kubernetes cluster hosted on GKE.
The problem is when I'm checking if the elasticsearch cluster is running I can find my stateful sets but without pod.
So I check, the count is set to 0 (in my manifest it sets to 1).
When I tried to set the replica to 1, I have an other error:

create Pod datawarehouse-es-master-europe-west1-c-0 in StatefulSet datawarehouse-es-master-europe-west1-c failed error: Pod "datawarehouse-es-master-europe-west1-c-0" is invalid: spec.containers[0].image: Required value

So it seems I miss something but I don't understand where is the issue, my elasticsearch resource have an image and count, if someone can help i would be awesome.

I share with you my manifests: https://gist.github.com/Dudesons/e042c7e42b94bb8f14b3e2e5537831a0

Hi,

It's a bit difficult to decipher the formatted YAML you have posted but I suspect the issue is that the container name in nodeSets.podTemplate.spec.containers is set to master-europe-west1-b instead of elasticsearch. In order to apply heap size and other custom settings, the container name must be named elasticsearch. See: https://www.elastic.co/guide/en/cloud-on-k8s/current/k8s-pod-template.html

If you are still having issues after changing the container name, please post the actual YAML manifests you applied or the output from kubectl get elasticsearch datawarehouse -o yaml here.

1 Like

Thank you for your response, it works now