ECK 1.4.1 dry run is not working

ECK dry run is not working giving:

Error from server (BadRequest): admission webhook "elastic-es-validation-v1.k8s.elastic.co" does not support dry run

ES version is 7.9.3.

kubernetes version is v1.18.16

Side effects on the validating web hook are still unknown after 1.4.1 upgrade:

kubectl describe ValidatingWebhookConfiguration elastic-webhook.k8s.elastic.co | grep "Side Effects"
Side Effects: Unknown
Side Effects: Unknown
Side Effects: Unknown
Side Effects: Unknown
Side Effects: Unknown
Side Effects: Unknown
Side Effects: Unknown
Side Effects: Unknown
Side Effects: Unknown

Is there something I have to do to get them to update to sideEffects=None.

If you install ECK using the Helm chart, the side effects property will be set to the correct value if you are on a Kubernetes version that supports it. If you use the all-in-one.yaml method to install ECK, you will need to edit the webhook definition yourself (or use a tool like Kustomize) to set the side effects property manually. This is because the all-in-one is tailored to the lowest common denominator of supported Kubernetes versions and we still support some older versions that are not aware of the side effects property.

Cool, thanks. I read the parts about setting the correct value itself, and thought that the operator made that decision.

BTW, is there any guidance or methodology on replacing the all-in-one with the helm chart? The helm chart was in infant when I got started with eck, so I used the all-in-one. I am not specializing anything at the moment.

We have migration instructions at Install ECK using the Helm chart | Elastic Cloud on Kubernetes [1.4] | Elastic

Sorry, I somehow missed that in the manual. Though the instructions should probably include labeling and annotating the elastic-operator configmap. Though I guess it says you can delete everything but the crds.