Elastic Agent (Fleet Deployment) behind a proxy

I'm testing the generic elastic agent with the endpoint security integration.
I had some problems because I'm using a custom CA, but luckily the tips in https://github.com/elastic/kibana/issues/73483 helped me and now I have data in my ES.

The other problem that I had experienced is that because I'm using the Elastic Agent behind my corporate proxy when the agent tried to download the endpoint security it failed.

Does exists any configuration in order to configure a proxy? For testing purposes I've downloaded the endpoint package manually, but it is not practical if you plan a massive deploy.

Thank you very much in advance

1 Like

These are all options that I used whenever I had proxy related issues.

    export HTTP_PROXY="http://user:password@ip:port"
    export HTTPS_PROXY="https://user:password@ip:port"
    export HTTP_PROXY="ip:port"
    export HTTPS_PROXY="ip:port"
    export HTTP_PROXY_USER="user"
    export HTTP_PROXY_PASS="password"
    export HTTPS_PROXY_USER="user"
    export HTTPS_PROXY_PASS="password"

https_proxy=http://user@haslo:ip:port HTTPS_PROXY=http://user@haslo:ip:port JRUBY_OPTS='-J-Dhttp.proxyHost=ip -J-Dhttp.proxyPort=port -J-Dhttp.proxyUser=user -J-Dhttp.proxyPassword=haslo' DEBUG=1 /usr/share/logstash/bin/logstash-plugin install logstash-input-wmi
1 Like

Hi Adriann,
I'm using windows, the proxy is configured in the proxy settings, but still not working

Thank you

What is the error code? Did you check if proxy is not preventing the connection?

Yes, It is not reaching the proxy at all.
I was able to download the package manually via browser using the proxy


Try starting the agent with this parameters

https_proxy=http://user@haslo:ip:port HTTPS_PROXY=http://user@haslo:ip:port JRUBY_OPTS='-J-Dhttp.proxyHost=ip -J-Dhttp.proxyPort=port -J-Dhttp.proxyUser=user -J-Dhttp.proxyPassword=haslo' DEBUG=1 /usr/share/

I'll and I'll let you know the results
Thank you

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.