Elastic agent not shipping data

Hello everyone, I am new to ELK.
Recently, I got access to a server which is running Vagrant and many other stuff.
My mission is to mainly deploy ELK on a VM that will be running on Vagrant.
I followed the steps mentionned on the documentation and the stack is up.
I tried to ship data with Elastic Agents and Fleet but my agents don't seem to be shipping data. I have come across many diagnostics and I personally think the problem is Elasticsearch is refusing connection from external hosts.
When I tried curl locally, it works:

curl --cacert certs/http_ca.crt -u elastic https://localhost:9200
Enter host password for user 'elastic':
  "name" : "ubuntu1810.localdomain",
  "cluster_name" : "elasticsearch",
  "cluster_uuid" : "Msx7BBzAQhGGHC3lBVYBCw",
  "version" : {
    "number" : "8.0.1",
    "build_flavor" : "default",
    "build_type" : "deb",
    "build_hash" : "801d9ccc7c2ee0f2cb121bbe22ab5af77a902372",
    "build_date" : "2022-02-24T13:55:40.601285296Z",
    "build_snapshot" : false,
    "lucene_version" : "9.0.0",
    "minimum_wire_compatibility_version" : "7.17.0",
    "minimum_index_compatibility_version" : "7.0.0"
  "tagline" : "You Know, for Search"

I have stuck at this point for a week and a half now. Any help would be deeply appreciated.Preformatted text


  1. I have deployed a Ubuntu 18.04 VM on which I installed elastic agent and it's shipping data as intended (as I told you, I am running ELK on a VM that is running on Vagrant)

  2. anything outside that environment doesn't seem to be able to ship data nor to be installed sometimes.

I have tried to install packetbeat but when running "packetbeat setup -e" it displays: Error connecting to Elasticsearch host"

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.