Elastic cloud - Cluster failing to restart - log4j JVM security issue

Hello there,

Is anyone else experiencing problems restarting their older version <7.2 elastic cloud cluster?
I am following the recommendation for the Log4j vulnerability, which is for cloud users to restart their clusters. But in my case, it is not passing the 'Validating prerequisites' step.

Solutions and Mitigations:

Deployments hosted in Elastic Cloud have been updated to leverage the JVM Option -Dlog4j2.formatMsgNoLookups=true which will take effect on restart of the deployment and on any config change to the Elasticsearch deployment.

For users running a cluster on a minor version older than 7.2, we recommend a restart.

The simplest way to restart a deployment is to do the following:

  1. Log in to the Cloud UI. Navigate to the “deployments” section in Elasticsearch Service.
  2. Select the deployment you’d like to restart.
  3. In the “manage” menu, select “restart”. Any kind of restart will work: “no downtime” restarts are fine.
1 Like

Please see Support for Elastic Cloud, Hosted Elasticsearch | Elastic on how to raise a support ticket for Elastic Cloud :slight_smile:

Hi dadoonet,
I do have a ticket open with Elastic, but it is looking like they will take the 72h to get to it, not exactly to have it solved.
And at this point, I can't even see the snapshots on the dashboard anymore.

@Ralph_v Did you try to reapply the plan / restart again?

Hi stephenb,
I did try restarting multiple times, and with different configuration also. Nothing worked

Earlier today there was a restart requested by 'system' and the cluster is online again. I am waiting on support to learn what was the issue.
But at this point, I am afraid of restarting other clusters.

Yes / Agree I would wait till you hear back from Support.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.