Elastic Cloud - xpack.management.enabled not working for logstash


#1

I'm trying out Elastic Cloud ( trial ) and I couldn't find a category for it, so I apologize if this is in the wrong place.

I'm trying to enable management for logstash pipelines, but I get an error message that makes me confused:

[ERROR] 2018-11-07 09:07:33.105 [main] elasticsearchsource - X-Pack is installed on Logstash but not on Elasticsearch. Please install X-Pack on Elasticsearch to use the monitoring feature. Other features may be available.
[FATAL] 2018-11-07 09:07:33.125 [main] runner - An unexpected error occurred! {:error=>#<LogStash::LicenseChecker::LicenseError: X-Pack is installed on Logstash but not on Elasticsearch. Please install X-Pack on Elasticsearch to use the monitoring feature. Other features may be available.>, :backtrace=>["/usr/share/logstash/x-pack/lib/license_checker/licensed.rb:67:in `with_license_check'", "/usr/share/logstash/x-pack/lib/config_management/elasticsearch_source.rb:46:in `initialize'", "/usr/share/logstash/x-pack/lib/config_management/hooks.rb:41:in `after_bootstrap_checks'", "org/logstash/execution/EventDispatcherExt.java:69:in `execute'", "/usr/share/logstash/logstash-core/lib/logstash/runner.rb:293:in `execute'", "/usr/share/logstash/vendor/bundle/jruby/2.3.0/gems/clamp-0.6.5/lib/clamp/command.rb:67:in `run'", "/usr/share/logstash/logstash-core/lib/logstash/runner.rb:237:in `run'", "/usr/share/logstash/vendor/bundle/jruby/2.3.0/gems/clamp-0.6.5/lib/clamp/command.rb:132:in `run'", "/usr/share/logstash/lib/bootstrap/environment.rb:73:in `<main>'"]}
[ERROR] 2018-11-07 09:07:33.139 [main] Logstash - java.lang.IllegalStateException: Logstash stopped processing because of an error: (SystemExit) exit

Elastic Cloud has X-Pack enabled by default and since I have the Security part under Management in Kibana I'm sure that it's enabled.
Also, monitoring is enabled on the cluster as well.

My X-Pack settings for management in logstash:

 xpack:
     management:
       enabled: true
       elasticsearch:
         url: ${ELASTICSEARCH}
         username: ${LOGSTASH_ADMIN}
         password: ${LOGSTASH_ADMIN_PASSWORD}
       logstash:
         poll_interval: 5s
       pipeline:
         id: ["indexer-0-apps-pipeline", "indexer-0-docker-pipeline"]

Any ideas what I am doing wrong or how to enable the pipeline management on elastic cloud?

Thank you


(Mark Walkom) #2

You can reach support for that here - https://www.elastic.co/cloud/as-a-service/support :slight_smile:


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.