Elastic Elasticsearch load balancer handshake failed

How do I deploy the load balancing Elasticsearch node to communicate elasticsearch cluster within Docker containers? I am running an basic elastic license.

Because I am failing on the handshake between the Kibana with Elasticsearch coordinating node and the master node of the cluster. Am I right to assume that this deals with licensing or xpack.security configurations?

Also in the documentation:
transport.tcp.port: 9300 - 9400
Does this need to be included since the transport host by default the network host and the transport.tcp.port are already set to 9300 -9400. When included it throw a weird bind error while without it, it does the same host and same ports. Am I missing something here?
URL to document: https://www.elastic.co/guide/en/kibana/current/production.html

Information about the environment:
Each Node is running inside of a docker container.

error message in docker log:

[2018-03-22T01:15:12,863][INFO ][o.e.d.z.ZenDiscovery ] [elasticsearch-lb] failed to send join request to master [{elasticsearch-2}{UTGDafhjT6qz-KOqufaxUQ}{QPlPlNUoRb-OwVZ54DzJRw}{xx.xxx.xx.xxx}{xx.xxx.xx.xxx:9300}{ml.machine_memory=16658759680, ml.max_open_jobs=20, ml.enabled=true}], reason [RemoteTransportException[[elasticsearch-2][xxx.xxx.xx.xxx:9300][internal:discovery/zen/join]]; nested: ConnectTransportException[[elasticsearch-lb][] handshake failed. unexpected remote node {elasticsearch-2}{UTGDafhjT6qz-KOqufaxUQ}{QPlPlNUoRb-OwVZ54DzJRw}{xx.xxx.xx.xxx}{xx.xxx.xx.xxx:9300}{ml.machine_memory=16658759680, ml.max_open_jobs=20, ml.enabled=true}]; ]

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.