Проблемы с хапуском elastic-hadoop


(Роберт Севумян) #1

Добрый вечер. При попытке установить elastic-yarne на cloudera возникли проблемы. При попытке старта эластика командой hadoop jar elastic-yarne-.jar - start выдаёт Exceptions in thread "main" jav

a.lang.NoClassdeffou dError: java/lang/Autocloseable и дальше список библиотек. Подскажите, пожалуйста, в чем причина данного поведения? Elasticsearch версии 1.7.1, elastic-hadoop версии 2.1.1, cloudera версии 5.3. Может ли быть причиной то, что используется версия клоудеры, которой нету в спискеподдерживаемых? Максимально поддерживаемая версия 5.2. И если жа ожидается ли такая поддержка. Спасибо


(Igor Motov) #2

Посоветовался с главным разработчиком проекта, который сказал, что Вам нужно перейти с JDK 6 на JDK 7 (как минимум), а лучше на JDK 8. Полный список рекомендуемых и поддерживаемых версий можно найти тут.


(Роберт Севумян) #3

Спасибо большое. Да, действительно, причиной всего была версия JDK.


(system) #4