Elastic process dies immediately after startup


(Tommy Noonan) #1

I've got a data node (2.3.4) that once fired up dies almost immediately with the following in the log file

[admin@rfdesdata2 logs]$ tail -1000lf ./rfd-performance.log
[2016-08-21 17:33:38,278][DEBUG][bootstrap ] seccomp(SECCOMP_SET_MODE_FILTER): Function not implemented, falling back to prctl(PR_SET_SECCOMP)...
[2016-08-21 17:33:38,279][DEBUG][bootstrap ] Linux seccomp filter installation successful, threads: [app]

Running on centos 7. I've got an identical data node that has the exact same os and setup(i think...) that is running fine. I'm stumped by this...any ideas?


(Mark Walkom) #2

Is that all that is in the log? What happens if you call the ES binary directly?


(Tommy Noonan) #3

Strangely, yes that's all that shows up when set to debug.

when i run the binary directly i get this.

[admin@rfdesdata2 bin]$ ./elasticsearch
Killed


(Tommy Noonan) #4

I was beginning to think perhaps a permissions issue. Validate ownership and execution for my admin user. That user is also in sudoers and can execute anything. Disabled selinux (put in permissive mode) as well.

Same result, process even called directly is Killed immediately??? This is just plain weird.


(Tommy Noonan) #5

Hate to keep responding to my own thread, but continuing to report. :wink:

I had the original ES gzip file locally and re-extracted to another location on the same host. That fired up fine running directly. Backed up my config files and laid down a fresh copy of the binaries in the original location. Fired up directly...it worked. Killed the process and put my config back in place....it worked???

Something got corrupt or was missing...i guess??? Well, mystery solved somewhat, who knows? I would have expected something more in the logs. One step i left out was to tar up the distro that i have deployed prior to laying down a fresh on top....i had enough weirdness for today...

Thanks for the feedback.


(Carlosvega) #6

Did you manage to know the answer?

It happens the same to me.


(system) #7