Elastic Search: Fix cluster health Red using JDBC River


(James Crone) #1

Hello..

My Index Settings:

PUT usersdata
{
"settings": {
"index": {
"number_of_shards": 3,
"number_of_replicas": 2,
"analysis": {
"analyzer": {
"analyzer_keyword": {
"tokenizer": "keyword",
"filter": "lowercase"
}
}
}
}
},
"mappings": {
"users": {
"properties": {
"Name": {
"analyzer": "analyzer_keyword",
"type": "string"
}
}
}
}
}

Index River JDBC Settings:

POST _river/usersdatariver/_meta
{
"type" : "jdbc",
"jdbc" : {
"url" : "jdbc:mysql://localhost:3306/alterduden",
"user" : "root",
"password" : "",
"poll" : "6s",
"index" : "usersdata",
"type" : "users",
"schedule":"0/10 * * ? * *",
"strategy" : "simple",
"sql" : "select ID,Name,DateTime,First_Name,Last_Name,ID as _id from
users"
}
}

I am using elasticsearch-1.5.0+marvel+elasticHQ plugins in LAN server but
clustername and node name is different. When i create index its run fine
for first time but when i restart elastic search status get RED.

{
"cluster_name" : "mycluster",
"status" : "red",
"timed_out" : false,
"number_of_nodes" : 2,
"number_of_data_nodes" : 1,
"active_primary_shards" : 6,
"active_shards" : 6,
"relocating_shards" : 0,
"initializing_shards" : 0,
"unassigned_shards" : 26,
"number_of_pending_tasks" : 0
}

how to fix this problem?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/c8f33c6c-5e9e-4873-afcd-af9077825e64%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Jörg Prante) #2

There should be error messages in the server log file of ES.

Jörg

On Sat, May 2, 2015 at 12:47 PM, James Crone arafay696@gmail.com wrote:

Hello..

My Index Settings:

PUT usersdata
{
"settings": {
"index": {
"number_of_shards": 3,
"number_of_replicas": 2,
"analysis": {
"analyzer": {
"analyzer_keyword": {
"tokenizer": "keyword",
"filter": "lowercase"
}
}
}
}
},
"mappings": {
"users": {
"properties": {
"Name": {
"analyzer": "analyzer_keyword",
"type": "string"
}
}
}
}
}

Index River JDBC Settings:

POST _river/usersdatariver/_meta
{
"type" : "jdbc",
"jdbc" : {
"url" : "jdbc:mysql://localhost:3306/alterduden",
"user" : "root",
"password" : "",
"poll" : "6s",
"index" : "usersdata",
"type" : "users",
"schedule":"0/10 * * ? * *",
"strategy" : "simple",
"sql" : "select ID,Name,DateTime,First_Name,Last_Name,ID as _id
from users"
}
}

I am using elasticsearch-1.5.0+marvel+elasticHQ plugins in LAN server but
clustername and node name is different. When i create index its run fine
for first time but when i restart elastic search status get RED.

{
"cluster_name" : "mycluster",
"status" : "red",
"timed_out" : false,
"number_of_nodes" : 2,
"number_of_data_nodes" : 1,
"active_primary_shards" : 6,
"active_shards" : 6,
"relocating_shards" : 0,
"initializing_shards" : 0,
"unassigned_shards" : 26,
"number_of_pending_tasks" : 0
}

how to fix this problem?

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/c8f33c6c-5e9e-4873-afcd-af9077825e64%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/c8f33c6c-5e9e-4873-afcd-af9077825e64%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAKdsXoFvxCQqWE1DeKqDAp7sfnau5obJmTsn6Jr4b0feEZgPmw%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(system) #3