Elastic Search hangs after start on Linux VM


I am running Elastic Search 6.5.4 on small Linux VM in dev mode. It is started successfully,
I can access http://localhost:9200 in browser perfectly.
But when Kibana is run and it start using ES, ES gets hanged. Now, accessing above URL in browser keeps on spinning. This also happens if I try to put any pipeline or index template using REST call. Basically, it is seeming that after some calls to ES, it starts hanging.
There are no exceptions in the logs.
Can you please let me know what can be wrong here?

How small is the VM? How much heap did you allocate to Elasticsearch?

I allocated XMX and XMS both as 512M. VM memory is 4 GB

What kind of VM is it? How much CPU do you have available? What does top show?

TOP showing below for ES process
6285 88 20 0 3338M 226M 34M sleep 0:16 0.80% java
There is only 1 CPU with Thread(s) per core: 1

I tried it on a good VM and it seems to be working. I think this can be closed as of now.

@ Christian_Dahlqvist
Coming here again.. now I tried it running on a Linux machine with 12 cores and 6 threads/core. Machine has around 16GB RAM with 8-10GB in use.
ES started running and I can put pipeline def and index template.
But filebeat bulk index operation fails with 504 error. And browser also keeps on spinning after some time.

Please show the full error as well as your config.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.