Elastic search not binding with server ip in centos

I am trying to access Elastic Search remotely, but getting elastic search stopped or dead .
When I set to default and curl localhost:9200 in the remote server, I get the desired output. But remotely server_address:9200 is not accessible. Elasticsearch stop working and shows the status elasticsearch is dead or elastic Search is stopped and even am not able to form cluster in server give me any solutions or Any suggestions?

This my elasticsearch.yml config

# Set the bind address to a specific IP (IPv4 or IPv6):
network.host: Server_ip
#Set a custom port for HTTP:
http.port: 9200

# For more information, consult the network module documentation.
# --------------------------------- Discovery    -------------
# Pass an initial list of hosts to perform discovery when new node is started:
# The default list of hosts is ["", "[::1]"]
discovery.zen.ping.unicast.hosts: ["Server_ip"]
# Prevent the "split brain" by configuring the majority of nodes (total number of master-eligible nodes / 2 + 1):
discovery.zen.minimum_master_nodes: 2
# For more information, consult the zen discovery module documentation

And am getting this type log error in my log file

[2017-06-29T17:52:51,366][INFO ][o.e.t.TransportService   ] [ibm-node- cluster] publish_address {}, bound_addresses {}
[2017-06-29T17:52:51,371][INFO ][o.e.b.BootstrapChecks    ] [ibm-node-cluster] bound or publishing to a non-loopback or non-link-local address, enforcing bootstrap checks
[2017-06-29T17:52:51,373][ERROR][o.e.b.Bootstrap          ] [ibm-node-cluster] node validation exception
[2] bootstrap checks failed
[1]: max number of threads [1024] for user [elasticsearch] is too low, increase to at least [2048]
[2]: system call filters failed to install; check the logs and fix your configuration or disable system call filters at your own risk
[2017-06-29T17:52:51,380][INFO ][o.e.n.Node               ] [ibm-node-cluster] stopping ...
[2017-06-29T17:52:51,468][INFO ][o.e.n.Node               ] [ibm-node-cluster] stopped
[2017-06-29T17:52:51,468][INFO ][o.e.n.Node               ] [ibm-node-cluster] closing ...
[2017-06-29T17:52:51,476][INFO ][o.e.n.Node               ] [ibm-node-cluster] closed
[2017-06-29T17:57:10,683][WARN ][o.e.b.JNANatives         ] unable to  install syscall filter:
java.lang.UnsupportedOperationException: seccomp unavailable:  CONFIG_SECCOMP not compiled into kernel, CONFIG_SECCOMP and  CONFIG_SECCOMP_FILTER are needed
        at  org.elasticsearch.bootstrap.SystemCallFilter.linuxImpl(SystemCallFilter.java:3 63) ~[elasticsearch-5.4.3.jar:5.4.3]
        at org.elasticsearch.bootstrap.SystemCallFilter.init(SystemCallFilter.java:638) ~[elasticsearch-5.4.3.jar:5.4.3]
        at org.elasticsearch.bootstrap.JNANatives.tryInstallSystemCallFilter(JNANatives.java:215) [elasticsearch-5.4.3.jar:5.4.3]
        at org.elasticsearch.bootstrap.Natives.tryInstallSystemCallFilter(Natives.java:99) [elasticsearch-5.4.3.jar:5.4.3]
        at org.elasticsearch.bootstrap.Bootstrap.initializeNatives(Bootstrap.java:111) [elasticsearch-5.4.3.jar:5.4.3]
         at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:194) [elasticsearch-5.4.3.jar:5.4.3]
        at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:350) [elasticsearch-5.4.3.jar:5.4.3]
        at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:123) [elasticsearch-5.4.3.jar:5.4.3]
        at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:114) [elasticsearch-5.4.3.jar:5.4.3]

Please read https://www.elastic.co/guide/en/elasticsearch/reference/current/bootstrap-checks.html

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.