Elastic Search server raise Exception:java.net.SocketException: Network is unreachable: no further information


(chengji18) #1

When I try to run my Elasticsearch server, It give me an exception,
normally it should be work,
Implement:
Location>>Elasticsearch>>elasticsearch-0.90.5>>bin>>elasticsearch.bat

https://lh4.googleusercontent.com/-KAqSkZPe1rs/UqA4kpiRsSI/AAAAAAAAAC0/v40iUoOb9I0/s1600/ScreenClip.png

The version of my elasticsearch server is 0.90.5
I use windows 7 64 bits.
It is single node with 5 default shards.

Any solution to solve this? Thank you

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/e3c99e4a-a40b-4fc6-ad62-b1642ff50a02%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Jason Wee) #2

Hi,

Did you try check if this node is accessible from other nodes and vice
versa? It could be probably network issue (e.g. ip block , port
unreachable).

/Jason

On Thu, Dec 5, 2013 at 4:28 PM, cml funny1990525@gmail.com wrote:

When I try to run my Elasticsearch server, It give me an exception,
normally it should be work,
Implement:
Location>>Elasticsearch>>elasticsearch-0.90.5>>bin>>elasticsearch.bat

https://lh4.googleusercontent.com/-KAqSkZPe1rs/UqA4kpiRsSI/AAAAAAAAAC0/v40iUoOb9I0/s1600/ScreenClip.png

The version of my elasticsearch server is 0.90.5
I use windows 7 64 bits.
It is single node with 5 default shards.

Any solution to solve this? Thank you

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/e3c99e4a-a40b-4fc6-ad62-b1642ff50a02%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAHO4itzWc-eLnSibWFRXr1bLefhXDSjz%2Bi84TEYdmSCRcbG7RA%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(chengji18) #3

Hi json,
In my case, I only do it in my local machine, there is no more machine and
node. So I think the elasticsearch localhost is only talk to the local host
in my case.
I am a quite new elasticsearch user,
what I think could be the port is not accessable now. Last time it works
and is the port 9200, and right now it is not possible to connect that
port.
Any more suggestion?

2013/12/5 Jason Wee peichieh@gmail.com

Hi,

Did you try check if this node is accessible from other nodes and vice
versa? It could be probably network issue (e.g. ip block , port
unreachable).

/Jason

On Thu, Dec 5, 2013 at 4:28 PM, cml funny1990525@gmail.com wrote:

When I try to run my Elasticsearch server, It give me an exception,
normally it should be work,
Implement:
Location>>Elasticsearch>>elasticsearch-0.90.5>>bin>>elasticsearch.bat

https://lh4.googleusercontent.com/-KAqSkZPe1rs/UqA4kpiRsSI/AAAAAAAAAC0/v40iUoOb9I0/s1600/ScreenClip.png

The version of my elasticsearch server is 0.90.5
I use windows 7 64 bits.
It is single node with 5 default shards.

Any solution to solve this? Thank you

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.

To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/e3c99e4a-a40b-4fc6-ad62-b1642ff50a02%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/l63JljeTon0/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAHO4itzWc-eLnSibWFRXr1bLefhXDSjz%2Bi84TEYdmSCRcbG7RA%40mail.gmail.com
.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAP%3DYonVK%3Dqvmt61oa22LKx%2BdaCkSzC%3D%2Bpc09SYefynVSfiFDmw%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Alexander Reelsen) #4

Hey,

cant see anything totally obvious... I have absolutely no idea if the ipv6
stack under windows is reliable, maybe you can start elasticsearch using
the -Djava.net.preferIPv4Stack=true option and see if it is any different.
Maybe publish_address and bind_address are different due to ipv6.

--Alex

On Thu, Dec 5, 2013 at 9:56 AM, Fan Wang funny1990525@gmail.com wrote:

Hi json,
In my case, I only do it in my local machine, there is no more machine and
node. So I think the elasticsearch localhost is only talk to the local host
in my case.
I am a quite new elasticsearch user,
what I think could be the port is not accessable now. Last time it works
and is the port 9200, and right now it is not possible to connect that
port.
Any more suggestion?

2013/12/5 Jason Wee peichieh@gmail.com

Hi,

Did you try check if this node is accessible from other nodes and vice
versa? It could be probably network issue (e.g. ip block , port
unreachable).

/Jason

On Thu, Dec 5, 2013 at 4:28 PM, cml funny1990525@gmail.com wrote:

When I try to run my Elasticsearch server, It give me an exception,
normally it should be work,
Implement:
Location>>Elasticsearch>>elasticsearch-0.90.5>>bin>>elasticsearch.bat

https://lh4.googleusercontent.com/-KAqSkZPe1rs/UqA4kpiRsSI/AAAAAAAAAC0/v40iUoOb9I0/s1600/ScreenClip.png

The version of my elasticsearch server is 0.90.5
I use windows 7 64 bits.
It is single node with 5 default shards.

Any solution to solve this? Thank you

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.

To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/e3c99e4a-a40b-4fc6-ad62-b1642ff50a02%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/l63JljeTon0/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAHO4itzWc-eLnSibWFRXr1bLefhXDSjz%2Bi84TEYdmSCRcbG7RA%40mail.gmail.com
.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAP%3DYonVK%3Dqvmt61oa22LKx%2BdaCkSzC%3D%2Bpc09SYefynVSfiFDmw%40mail.gmail.com
.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAGCwEM9MQbXoYhpbF3CcHFZ54QBtMBccDM%2BJFHJTR8S7nkM%2Bgg%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #5