Elastic search snopshot azure repoistory

i need to save the elastic search snapshot in azure blobs container.
how to config the elastic search and azure repository?
i already installed azure repository plug in elastic Search.but not its show settings_exception ("Invalid azure client settings with name [default]") in kibana .

Not sure what is your version but here is the latest documentation available: https://www.elastic.co/guide/en/elasticsearch/plugins/current/repository-azure.html

If you still have troubles after reading and following the instructions, please share details like configuration file, all steps you did, the elasticsearch logs, ...

i am using then current version 7.1 but try add the storage account and key could not type in command prompt

also attach the yml file in Elasticsearh

======================== Elasticsearch Configuration =========================

NOTE: Elasticsearch comes with reasonable defaults for most settings.

Before you set out to tweak and tune the configuration, make sure you

understand what are you trying to accomplish and the consequences.

The primary way of configuring a node is via this file. This template lists

the most important settings you may want to configure for a production cluster.

Please consult the documentation for further information on configuration options:


---------------------------------- Cluster -----------------------------------

Use a descriptive name for your cluster:

#cluster.name: my-application

------------------------------------ Node ------------------------------------

Use a descriptive name for the node:

#node.name: node-1

Add custom attributes to the node:

#node.attr.rack: r1

----------------------------------- Paths ------------------------------------

Path to directory where to store the data (separate multiple locations by comma):

#path.data: /path/to/data

Path to log files:

#path.logs: /path/to/logs

----------------------------------- Memory -----------------------------------

Lock the memory on startup:

#bootstrap.memory_lock: true

Make sure that the heap size is set to about half the memory available

on the system and that the owner of the process is allowed to use this


Elasticsearch performs poorly when the system is swapping the memory.

---------------------------------- Network -----------------------------------

Set the bind address to a specific IP (IPv4 or IPv6):


Set a custom port for HTTP:

http.port: 9200

For more information, consult the network module documentation.

--------------------------------- Discovery ----------------------------------

Pass an initial list of hosts to perform discovery when this node is started:

The default list of hosts is ["", "[::1]"]

#discovery.seed_hosts: ["host1", "host2"]

Bootstrap the cluster using an initial set of master-eligible nodes:

#cluster.initial_master_nodes: ["node-1", "node-2"]

For more information, consult the discovery and cluster formation module documentation.

---------------------------------- Gateway -----------------------------------

Block initial recovery after a full cluster restart until N nodes are started:

#gateway.recover_after_nodes: 3

For more information, consult the gateway module documentation.

---------------------------------- Various -----------------------------------

Require explicit names when deleting indices:

#action.destructive_requires_name: true

path.repo: "https://pathfinderdiag631.blob.core.windows.net/dbbackup"

script.engine.groovy.inline.search: on

script.engine.groovy.inline.aggs: on

script.groovy.sandbox.enabled: true

path.repo: ["https://pathfinderdiag631.blob.core.windows.net/dbbackup"]

Please format your code, logs or configuration files using </> icon as explained in this guide and not the citation button. It will make your post more readable.

Or use markdown style like:


This is the icon to use if you are not using markdown format:

There's a live preview panel for exactly this reasons.

Lots of people read these forums, and many of them will simply skip over a post that is difficult to read, because it's just too large an investment of their time to try and follow a wall of badly formatted text.
If your goal is to get an answer to your questions, it's in your interest to make it as easy to read and understand as possible.
Please update your post.

Can you share the exact commands you used and what is the output? (No screenshot please).

PUT _snapshot/my_backup1
    "type": "azure"

"error": {
"root_cause": [
"type": "settings_exception",
"reason": "Invalid azure client settings with name [default]"
"type": "settings_exception",
"reason": "Invalid azure client settings with name [default]",
"caused_by": {
"type": "illegal_argument_exception",
"reason": "Invalid connection string."
"status": 500

So you did not follow the very first steps of the guide? https://www.elastic.co/guide/en/elasticsearch/plugins/current/repository-azure-usage.html

thank you dadoonet
i am able to create snopshot now , but i can't find any backups in azure blobs storage containers

thank you dadoonet

Please ignore the Previous comment, how to restore the snapshot in cluster

I think the documentation says it all: https://www.elastic.co/guide/en/elasticsearch/reference/current/modules-snapshots.html#_restore

i put the snapshot in elastic search its also stored in azure blob container, but i can't get any snapshots details

    PUT _snapshot/Test
    "type": "azure",
    "settings": {
       "container": "test",
         "compress": true,
        "base_path": "CarsElasticSearch\\Test"

GET /_cat/repositories

GET /_snapshot/Test/_all -- run this Comment i will get the below output


"snapshots" :

What is the output of the first command?

first output is
"acknowledged" : true

Just realized that you did not run any snapshot right? As the guide says, something like:

PUT /_snapshot/my_backup/snapshot_1?wait_for_completion=true
PUT _snapshot/Testing1
    "type": "azure",
    "settings": {
       "container": "dbbackup",
         "compress": true,
        "base_path": "CarsElasticSearch\\Testing1"

PUT /_snapshot/Testing1/snapshot_1?wait_for_completion=true


  "snapshot" : {
    "snapshot" : "snapshot_1",
    "uuid" : "YGCqKedAQf-qrs35b_ba4A",
    "version_id" : 7010099,
    "version" : "7.1.0",
    "indices" : [
    "include_global_state" : true,
    "state" : "SUCCESS",
    "start_time" : "2019-05-24T06:16:51.528Z",
    "start_time_in_millis" : 1558678611528,
    "end_time" : "2019-05-24T06:17:05.112Z",
    "end_time_in_millis" : 1558678625112,
    "duration_in_millis" : 13584,
    "failures" : [ ],
    "shards" : {
      "total" : 6,
      "failed" : 0,
      "successful" : 6

after run this comment

GET /_snapshot/Testing1/_status


  "snapshots" : [ ]

What is the output of:

GET /_snapshot/Testing1/_all

"snapshots" :

If all what you shared here is exact, then that could be a bug.
I did not test myself Azure snapshots for a long time so I can't tell. Might worth opening an issue in Elasticsearch github repository sharing all information and a link to this discussion?

thank you david,

I made small mistake but now it will work fine.
thanks for response :grinning::grinning::grinning: