Elastic search with CouchDB river plugin - Can't find any documents

I recently started using elastic search and couchdb and I have the
following problem. I have a couch database with a bunch of documents. I add
a couch db river index on elastic search and I expect to have those
documents indexed and searchable. But when I search for anything through ES
I dont get any results. The command flow is as follows:

The command above verifies that there are 4 documents in the couch db
instance

curl -H "Content-Type: application/json" -X GET http://localhost:5984/my_db

{"db_name":"my_db","doc_count":4,"doc_del_count":0,"update_seq":4,"purge_seq":0,"compact_running":false,"disk_size":16482,"data_size":646,"instance_start_time":"1370204643908592","disk_format_version":6,"committed_update_seq":4}

The _changes output:

curl -H "Content-Type: application/json" -X GET http://localhost:5984/my_db/_changes
{"results":[
{"seq":1,"id":"1","changes":[{"rev":"1-40d928a959dd52d183ab7c413fabca92"}]},
{"seq":2,"id":"2","changes":[{"rev":"1-42212757a56b240f5205266b1969e890"}]},
{"seq":3,"id":"3","changes":[{"rev":"1-f59c2ae7acacb68d9414be05d56ed33a"}]},
{"seq":4,"id":"4","changes":[{"rev":"1-e86cf1c287c16906e81d901365b9bf98"}]}
],
"last_seq":4}

Now, below I m creating my index in ES.

curl -XPUT 'http://localhost:9200/_river/my_db/_meta' -d '{ "type" : "couchdb", "couchdb" : { "host" : "localhost", "port" : 5984, "db" : "my_db", "filter" : null } }'

{"ok":true,"_index":"_river","_type":"my_db","_id":"_meta","_version":1}

But I dont get anything back.

curl -XGET "http://localhost:9200/my_db/my_db/_search?pretty=true"
{
"took" : 2,
"timed_out" : false,
"_shards" : {
"total" : 5,
"successful" : 5,
"failed" : 0
},
"hits" : {
"total" : 0,
"max_score" : null,
"hits" : [ ]
}
}

Is there anything I m missing?

Thanks, Yannis

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Not sure that default type is dbname.
What do you get with:
curl -XGET "http://localhost:9200/my_db/_search?q=*&pretty=true"
?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 4 juin 2013 à 23:26, Yannis Psarras yannis.psarras@gmail.com a écrit :

I recently started using elastic search and couchdb and I have the following problem. I have a couch database with a bunch of documents. I add a couch db river index on elastic search and I expect to have those documents indexed and searchable. But when I search for anything through ES I dont get any results. The command flow is as follows:

The command above verifies that there are 4 documents in the couch db instance

curl -H "Content-Type: application/json" -X GET http://localhost:5984/my_db

{"db_name":"my_db","doc_count":4,"doc_del_count":0,"update_seq":4,"purge_seq":0,"compact_running":false,"disk_size":16482,"data_size":646,"instance_start_time":"1370204643908592","disk_format_version":6,"committed_update_seq":4}
The _changes output:

curl -H "Content-Type: application/json" -X GET http://localhost:5984/my_db/_changes
{"results":[
{"seq":1,"id":"1","changes":[{"rev":"1-40d928a959dd52d183ab7c413fabca92"}]},
{"seq":2,"id":"2","changes":[{"rev":"1-42212757a56b240f5205266b1969e890"}]},
{"seq":3,"id":"3","changes":[{"rev":"1-f59c2ae7acacb68d9414be05d56ed33a"}]},
{"seq":4,"id":"4","changes":[{"rev":"1-e86cf1c287c16906e81d901365b9bf98"}]}
],
"last_seq":4}
Now, below I m creating my index in ES.

curl -XPUT 'http://localhost:9200/_river/my_db/_meta' -d '{ "type" : "couchdb", "couchdb" : { "host" : "localhost", "port" : 5984, "db" : "my_db", "filter" : null } }'

{"ok":true,"_index":"_river","_type":"my_db","_id":"_meta","_version":1}
But I dont get anything back.

curl -XGET "http://localhost:9200/my_db/my_db/_search?pretty=true"
{
"took" : 2,
"timed_out" : false,
"_shards" : {
"total" : 5,
"successful" : 5,
"failed" : 0
},
"hits" : {
"total" : 0,
"max_score" : null,
"hits" : [ ]
}
}
Is there anything I m missing?

Thanks, Yannis

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

I get the following:

curl -XGET "http://localhost:9200/my_db/_search?pretty=true
http://localhost:9200/my_db/my_db/_search?pretty=true"
{
"took" : 2,
"timed_out" : false,
"_shards" : {
"total" : 5,
"successful" : 5,
"failed" : 0
},
"hits" : {
"total" : 0,
"max_score" : null,
"hits" : [ ]
}
}

On Wed, Jun 5, 2013 at 12:53 AM, David Pilato david@pilato.fr wrote:

Not sure that default type is dbname.
What do you get with:

curl -XGET "http://localhost:9200/my_db/_search?q=*&pretty=true"

?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 4 juin 2013 à 23:26, Yannis Psarras yannis.psarras@gmail.com a
écrit :

I recently started using elastic search and couchdb and I have the
following problem. I have a couch database with a bunch of documents. I add
a couch db river index on elastic search and I expect to have those
documents indexed and searchable. But when I search for anything through ES
I dont get any results. The command flow is as follows:

The command above verifies that there are 4 documents in the couch db
instance

curl -H "Content-Type: application/json" -X GET http://localhost:5984/my_db

{"db_name":"my_db","doc_count":4,"doc_del_count":0,"update_seq":4,"purge_seq":0,"compact_running":false,"disk_size":16482,"data_size":646,"instance_start_time":"1370204643908592","disk_format_version":6,"committed_update_seq":4}

The _changes output:

curl -H "Content-Type: application/json" -X GET http://localhost:5984/my_db/_changes
{"results":[
{"seq":1,"id":"1","changes":[{"rev":"1-40d928a959dd52d183ab7c413fabca92"}]},
{"seq":2,"id":"2","changes":[{"rev":"1-42212757a56b240f5205266b1969e890"}]},
{"seq":3,"id":"3","changes":[{"rev":"1-f59c2ae7acacb68d9414be05d56ed33a"}]},
{"seq":4,"id":"4","changes":[{"rev":"1-e86cf1c287c16906e81d901365b9bf98"}]}
],
"last_seq":4}

Now, below I m creating my index in ES.

curl -XPUT 'http://localhost:9200/_river/my_db/_meta' -d '{ "type" : "couchdb", "couchdb" : { "host" : "localhost", "port" : 5984, "db" : "my_db", "filter" : null } }'

{"ok":true,"_index":"_river","_type":"my_db","_id":"_meta","_version":1}

But I dont get anything back.

curl -XGET "http://localhost:9200/my_db/my_db/_search?pretty=true"
{
"took" : 2,
"timed_out" : false,
"_shards" : {
"total" : 5,
"successful" : 5,
"failed" : 0
},
"hits" : {
"total" : 0,
"max_score" : null,
"hits" : [ ]
}
}

Is there anything I m missing?

Thanks, Yannis

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/FUJj2c4ycnc/unsubscribe?hl=en-US
.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

And with the q=* I get the same really as above

(for query: http://localhost:9200/my_db/_search?q=*&pretty=true)

On Wed, Jun 5, 2013 at 1:17 AM, Yannis Psarras yannis.psarras@gmail.comwrote:

I get the following:

curl -XGET "http://localhost:9200/my_db/_search?pretty=true http://localhost:9200/my_db/my_db/_search?pretty=true"
{
"took" : 2,
"timed_out" : false,
"_shards" : {
"total" : 5,
"successful" : 5,
"failed" : 0
},
"hits" : {
"total" : 0,
"max_score" : null,
"hits" : [ ]
}
}

On Wed, Jun 5, 2013 at 12:53 AM, David Pilato david@pilato.fr wrote:

Not sure that default type is dbname.
What do you get with:

curl -XGET "http://localhost:9200/my_db/_search?q=*&pretty=true"

?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 4 juin 2013 à 23:26, Yannis Psarras yannis.psarras@gmail.com a
écrit :

I recently started using elastic search and couchdb and I have the
following problem. I have a couch database with a bunch of documents. I add
a couch db river index on elastic search and I expect to have those
documents indexed and searchable. But when I search for anything through ES
I dont get any results. The command flow is as follows:

The command above verifies that there are 4 documents in the couch db
instance

curl -H "Content-Type: application/json" -X GET http://localhost:5984/my_db

{"db_name":"my_db","doc_count":4,"doc_del_count":0,"update_seq":4,"purge_seq":0,"compact_running":false,"disk_size":16482,"data_size":646,"instance_start_time":"1370204643908592","disk_format_version":6,"committed_update_seq":4}

The _changes output:

curl -H "Content-Type: application/json" -X GET http://localhost:5984/my_db/_changes
{"results":[
{"seq":1,"id":"1","changes":[{"rev":"1-40d928a959dd52d183ab7c413fabca92"}]},
{"seq":2,"id":"2","changes":[{"rev":"1-42212757a56b240f5205266b1969e890"}]},
{"seq":3,"id":"3","changes":[{"rev":"1-f59c2ae7acacb68d9414be05d56ed33a"}]},
{"seq":4,"id":"4","changes":[{"rev":"1-e86cf1c287c16906e81d901365b9bf98"}]}
],
"last_seq":4}

Now, below I m creating my index in ES.

curl -XPUT 'http://localhost:9200/_river/my_db/_meta' -d '{ "type" : "couchdb", "couchdb" : { "host" : "localhost", "port" : 5984, "db" : "my_db", "filter" : null } }'

{"ok":true,"_index":"_river","_type":"my_db","_id":"_meta","_version":1}

But I dont get anything back.

curl -XGET "http://localhost:9200/my_db/my_db/_search?pretty=true"
{
"took" : 2,
"timed_out" : false,
"_shards" : {
"total" : 5,
"successful" : 5,
"failed" : 0
},
"hits" : {
"total" : 0,
"max_score" : null,
"hits" : [ ]
}
}

Is there anything I m missing?

Thanks, Yannis

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/FUJj2c4ycnc/unsubscribe?hl=en-US
.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Just to double check, could you run:
http://localhost:9200/_search?q=*&pretty=true

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 5 juin 2013 à 00:19, Yannis Psarras yannis.psarras@gmail.com a écrit :

And with the q=* I get the same really as above

(for query: http://localhost:9200/my_db/_search?q=*&pretty=true)

On Wed, Jun 5, 2013 at 1:17 AM, Yannis Psarras yannis.psarras@gmail.com wrote:

I get the following:

curl -XGET "http://localhost:9200/my_db/_search?pretty=true"
{
"took" : 2,
"timed_out" : false,
"_shards" : {
"total" : 5,
"successful" : 5,
"failed" : 0
},
"hits" : {
"total" : 0,
"max_score" : null,
"hits" : [ ]
}
}

On Wed, Jun 5, 2013 at 12:53 AM, David Pilato david@pilato.fr wrote:

Not sure that default type is dbname.
What do you get with:

curl -XGET "http://localhost:9200/my_db/_search?q=*&pretty=true"
?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 4 juin 2013 à 23:26, Yannis Psarras yannis.psarras@gmail.com a écrit :

I recently started using elastic search and couchdb and I have the following problem. I have a couch database with a bunch of documents. I add a couch db river index on elastic search and I expect to have those documents indexed and searchable. But when I search for anything through ES I dont get any results. The command flow is as follows:

The command above verifies that there are 4 documents in the couch db instance

curl -H "Content-Type: application/json" -X GET http://localhost:5984/my_db

{"db_name":"my_db","doc_count":4,"doc_del_count":0,"update_seq":4,"purge_seq":0,"compact_running":false,"disk_size":16482,"data_size":646,"instance_start_time":"1370204643908592","disk_format_version":6,"committed_update_seq":4}
The _changes output:

curl -H "Content-Type: application/json" -X GET http://localhost:5984/my_db/_changes
{"results":[
{"seq":1,"id":"1","changes":[{"rev":"1-40d928a959dd52d183ab7c413fabca92"}]},
{"seq":2,"id":"2","changes":[{"rev":"1-42212757a56b240f5205266b1969e890"}]},
{"seq":3,"id":"3","changes":[{"rev":"1-f59c2ae7acacb68d9414be05d56ed33a"}]},
{"seq":4,"id":"4","changes":[{"rev":"1-e86cf1c287c16906e81d901365b9bf98"}]}
],
"last_seq":4}
Now, below I m creating my index in ES.

curl -XPUT 'http://localhost:9200/_river/my_db/_meta' -d '{ "type" : "couchdb", "couchdb" : { "host" : "localhost", "port" : 5984, "db" : "my_db", "filter" : null } }'

{"ok":true,"_index":"_river","_type":"my_db","_id":"_meta","_version":1}
But I dont get anything back.

curl -XGET "http://localhost:9200/my_db/my_db/_search?pretty=true"
{
"took" : 2,
"timed_out" : false,
"_shards" : {
"total" : 5,
"successful" : 5,
"failed" : 0
},
"hits" : {
"total" : 0,
"max_score" : null,
"hits" : [ ]
}
}
Is there anything I m missing?

Thanks, Yannis

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/elasticsearch/FUJj2c4ycnc/unsubscribe?hl=en-US.
To unsubscribe from this group and all its topics, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

David,

Sorry for the old post revival, but I'm getting this same error with no
hits with Couchdb rivers (2.4.1), Elasticsearch (1.4.2), and Couchdb
(1.6.1). I am fairly new to using couch-rivers but I've installed all the
applications and they are running on Centos 7. Can you please see if you
notice anything wrong? I've looked everywhere but can not find a solution.
Thank you in advance

I added some dummy data into my couchdb database "testdb":

curl -XGET localhost:5984/testdb/_changes

{"results":[
{"seq":1,"id":"1","changes":[{"rev":"1-0291....."}]},
{"seq":2,"id":"2","changes":[{"rev":"1-1945....."}]},
{"seq":3,"id":"3","changes":[{"rev":"1-62a5....."}]},
{"seq":4,"id":"4","changes":[{"rev":"1-7e93....."}]},
],
"last_seq":4}

I run this to make the index:

curl -X PUT 'http://localhost:9200/_river/testdb/_meta' -d '{ "type" :

"couchdb", "couchdb" : { "host" : "localhost", "port" : 5984, "db" :
"testdb", "filter" : null }"'

Get a return of:

{"index":"_river","_type":"testdb","_id":"_meta","_version":1,"created":true"}

When I try to do the query:

curl localhost:9200/testdb/testdb/_search?pretty=1

{
"took" : 1,
"timed_out" : false,
"_shards" : {
"total" : 5,
"successful" : 5,
"failed" : 0
},
"hits" : {
"total" : 0,
"max_score" : null,
"hits" : [ ]
}
}

When I use the

curl http://localhost:9200/_search?q=*&pretty=true

{
"took" : 2,
"timed_out" : false,
"_shards" : {
"total" : 16,
"successful" : 16,
"failed" : 0
},
"hits" : {
"total" : 1,
"max_score" : 1.0,
"hits" : [ {
"_index" : "_river",
"_type" : "testdb",
"_id" : "_meta",
"_score" : "1.0",
"_source" : {"type" "couchdb", "couchdb" : {"host" : "localhost",
"port": "5984", "db" : "testdb", "filter" : null}}
} ]
}
}

On Wednesday, June 5, 2013 at 1:59:04 AM UTC-4, David Pilato wrote:

Just to double check, could you run:
http://localhost:9200/_search?q=*&pretty=true
http://localhost:9200/my_db/_search?q=*&pretty=true

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 5 juin 2013 à 00:19, Yannis Psarras <yannis....@gmail.com <javascript:>>
a écrit :

And with the q=* I get the same really as above

(for query: http://localhost:9200/my_db/_search?q=*&pretty=true)

On Wed, Jun 5, 2013 at 1:17 AM, Yannis Psarras <yannis....@gmail.com
<javascript:>> wrote:

I get the following:

curl -XGET "http://localhost:9200/my_db/_search?pretty=true http://localhost:9200/my_db/my_db/_search?pretty=true"
{
"took" : 2,
"timed_out" : false,
"_shards" : {
"total" : 5,
"successful" : 5,
"failed" : 0
},
"hits" : {
"total" : 0,
"max_score" : null,
"hits" : [ ]
}
}

On Wed, Jun 5, 2013 at 12:53 AM, David Pilato <da...@pilato.fr
<javascript:>> wrote:

Not sure that default type is dbname.
What do you get with:

curl -XGET "http://localhost:9200/my_db/_search?q=*&pretty=true"

?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 4 juin 2013 à 23:26, Yannis Psarras <yannis....@gmail.com
<javascript:>> a écrit :

I recently started using elastic search and couchdb and I have the
following problem. I have a couch database with a bunch of documents. I add
a couch db river index on elastic search and I expect to have those
documents indexed and searchable. But when I search for anything through ES
I dont get any results. The command flow is as follows:

The command above verifies that there are 4 documents in the couch db
instance

curl -H "Content-Type: application/json" -X GET http://localhost:5984/my_db

{"db_name":"my_db","doc_count":4,"doc_del_count":0,"update_seq":4,"purge_seq":0,"compact_running":false,"disk_size":16482,"data_size":646,"instance_start_time":"1370204643908592","disk_format_version":6,"committed_update_seq":4}

The _changes output:

curl -H "Content-Type: application/json" -X GET http://localhost:5984/my_db/_changes
{"results":[
{"seq":1,"id":"1","changes":[{"rev":"1-40d928a959dd52d183ab7c413fabca92"}]},
{"seq":2,"id":"2","changes":[{"rev":"1-42212757a56b240f5205266b1969e890"}]},
{"seq":3,"id":"3","changes":[{"rev":"1-f59c2ae7acacb68d9414be05d56ed33a"}]},
{"seq":4,"id":"4","changes":[{"rev":"1-e86cf1c287c16906e81d901365b9bf98"}]}
],
"last_seq":4}

Now, below I m creating my index in ES.

curl -XPUT 'http://localhost:9200/_river/my_db/_meta' -d '{ "type" : "couchdb", "couchdb" : { "host" : "localhost", "port" : 5984, "db" : "my_db", "filter" : null } }'

{"ok":true,"_index":"_river","_type":"my_db","_id":"_meta","_version":1}

But I dont get anything back.

curl -XGET "http://localhost:9200/my_db/my_db/_search?pretty=true"
{
"took" : 2,
"timed_out" : false,
"_shards" : {
"total" : 5,
"successful" : 5,
"failed" : 0
},
"hits" : {
"total" : 0,
"max_score" : null,
"hits" : [ ]
}
}

Is there anything I m missing?

Thanks, Yannis

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com <javascript:>.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/FUJj2c4ycnc/unsubscribe?hl=en-US
.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/acdd73d6-e67a-4246-9dd5-75e99c6ffc31%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Try with:

localhost:9200/testdb/_search

I think you are using the default type name here which is not IIRC the river name.

HTH

David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 2 févr. 2015 à 11:43, Bao-Quan Ho ho.baoquan@gmail.com a écrit :

David,

Sorry for the old post revival, but I'm getting this same error with no hits with Couchdb rivers (2.4.1), Elasticsearch (1.4.2), and Couchdb (1.6.1). I am fairly new to using couch-rivers but I've installed all the applications and they are running on Centos 7. Can you please see if you notice anything wrong? I've looked everywhere but can not find a solution. Thank you in advance

I added some dummy data into my couchdb database "testdb":

curl -XGET localhost:5984/testdb/_changes

{"results":[
{"seq":1,"id":"1","changes":[{"rev":"1-0291....."}]},
{"seq":2,"id":"2","changes":[{"rev":"1-1945....."}]},
{"seq":3,"id":"3","changes":[{"rev":"1-62a5....."}]},
{"seq":4,"id":"4","changes":[{"rev":"1-7e93....."}]},
],
"last_seq":4}

I run this to make the index:

curl -X PUT 'http://localhost:9200/_river/testdb/_meta' -d '{ "type" : "couchdb", "couchdb" : { "host" : "localhost", "port" : 5984, "db" : "testdb", "filter" : null }"'

Get a return of:

{"index":"_river","_type":"testdb","_id":"_meta","_version":1,"created":true"}

When I try to do the query:

curl localhost:9200/testdb/testdb/_search?pretty=1

{
"took" : 1,
"timed_out" : false,
"_shards" : {
"total" : 5,
"successful" : 5,
"failed" : 0
},
"hits" : {
"total" : 0,
"max_score" : null,
"hits" : [ ]
}
}

When I use the

curl http://localhost:9200/_search?q=*&pretty=true

{
"took" : 2,
"timed_out" : false,
"_shards" : {
"total" : 16,
"successful" : 16,
"failed" : 0
},
"hits" : {
"total" : 1,
"max_score" : 1.0,
"hits" : [ {
"_index" : "_river",
"_type" : "testdb",
"_id" : "_meta",
"_score" : "1.0",
"_source" : {"type" "couchdb", "couchdb" : {"host" : "localhost", "port": "5984", "db" : "testdb", "filter" : null}}
} ]
}
}

On Wednesday, June 5, 2013 at 1:59:04 AM UTC-4, David Pilato wrote:
Just to double check, could you run:
http://localhost:9200/_search?q=*&pretty=true

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 5 juin 2013 à 00:19, Yannis Psarras yannis....@gmail.com a écrit :

And with the q=* I get the same really as above

(for query: http://localhost:9200/my_db/_search?q=*&pretty=true)

On Wed, Jun 5, 2013 at 1:17 AM, Yannis Psarras yannis....@gmail.com wrote:
I get the following:

curl -XGET "http://localhost:9200/my_db/_search?pretty=true"
{
"took" : 2,
"timed_out" : false,
"_shards" : {
"total" : 5,
"successful" : 5,
"failed" : 0
},
"hits" : {
"total" : 0,
"max_score" : null,
"hits" : [ ]
}
}

On Wed, Jun 5, 2013 at 12:53 AM, David Pilato da...@pilato.fr wrote:
Not sure that default type is dbname.
What do you get with:
curl -XGET "http://localhost:9200/my_db/_search?q=*&pretty=true"
?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 4 juin 2013 à 23:26, Yannis Psarras yannis....@gmail.com a écrit :

I recently started using elastic search and couchdb and I have the following problem. I have a couch database with a bunch of documents. I add a couch db river index on elastic search and I expect to have those documents indexed and searchable. But when I search for anything through ES I dont get any results. The command flow is as follows:

The command above verifies that there are 4 documents in the couch db instance

curl -H "Content-Type: application/json" -X GET http://localhost:5984/my_db

{"db_name":"my_db","doc_count":4,"doc_del_count":0,"update_seq":4,"purge_seq":0,"compact_running":false,"disk_size":16482,"data_size":646,"instance_start_time":"1370204643908592","disk_format_version":6,"committed_update_seq":4}
The _changes output:

curl -H "Content-Type: application/json" -X GET http://localhost:5984/my_db/_changes
{"results":[
{"seq":1,"id":"1","changes":[{"rev":"1-40d928a959dd52d183ab7c413fabca92"}]},
{"seq":2,"id":"2","changes":[{"rev":"1-42212757a56b240f5205266b1969e890"}]},
{"seq":3,"id":"3","changes":[{"rev":"1-f59c2ae7acacb68d9414be05d56ed33a"}]},
{"seq":4,"id":"4","changes":[{"rev":"1-e86cf1c287c16906e81d901365b9bf98"}]}
],
"last_seq":4}
Now, below I m creating my index in ES.

curl -XPUT 'http://localhost:9200/_river/my_db/_meta' -d '{ "type" : "couchdb", "couchdb" : { "host" : "localhost", "port" : 5984, "db" : "my_db", "filter" : null } }'

{"ok":true,"_index":"_river","_type":"my_db","_id":"_meta","_version":1}
But I dont get anything back.

curl -XGET "http://localhost:9200/my_db/my_db/_search?pretty=true"
{
"took" : 2,
"timed_out" : false,
"_shards" : {
"total" : 5,
"successful" : 5,
"failed" : 0
},
"hits" : {
"total" : 0,
"max_score" : null,
"hits" : [ ]
}
}
Is there anything I m missing?

Thanks, Yannis

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/elasticsearch/FUJj2c4ycnc/unsubscribe?hl=en-US.
To unsubscribe from this group and all its topics, send an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/acdd73d6-e67a-4246-9dd5-75e99c6ffc31%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/F820A4DF-BC87-4C49-B3E2-2F8BC9ABDAD6%40pilato.fr.
For more options, visit https://groups.google.com/d/optout.

Hello I tried as suggested but I get the same outcome:

curl localhost:9200/testdb/_search?pretty=1

{
"took" : 1,
"timed_out" : false,
"_shards" : {
"total" : 5,
"successful" : 5,
"failed" : 0
},
"hits" : {
"total" : 0,
"max_score" : null,
"hits" : [ ]
}
}

On Mon, Feb 2, 2015 at 6:35 AM, David Pilato david@pilato.fr wrote:

Try with:

localhost:9200/testdb/_search

I think you are using the default type name here which is not IIRC the
river name.

HTH

David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 2 févr. 2015 à 11:43, Bao-Quan Ho ho.baoquan@gmail.com a écrit :

David,

Sorry for the old post revival, but I'm getting this same error with no
hits with Couchdb rivers (2.4.1), Elasticsearch (1.4.2), and Couchdb
(1.6.1). I am fairly new to using couch-rivers but I've installed all the
applications and they are running on Centos 7. Can you please see if you
notice anything wrong? I've looked everywhere but can not find a
solution. Thank you in advance

I added some dummy data into my couchdb database "testdb":

curl -XGET localhost:5984/testdb/_changes

{"results":[
{"seq":1,"id":"1","changes":[{"rev":"1-0291....."}]},
{"seq":2,"id":"2","changes":[{"rev":"1-1945....."}]},
{"seq":3,"id":"3","changes":[{"rev":"1-62a5....."}]},
{"seq":4,"id":"4","changes":[{"rev":"1-7e93....."}]},
],
"last_seq":4}

I run this to make the index:

curl -X PUT 'http://localhost:9200/_river/testdb/_meta' -d '{ "type" :

"couchdb", "couchdb" : { "host" : "localhost", "port" : 5984, "db" :
"testdb", "filter" : null }"'

Get a return of:

{"index":"_river","_type":"testdb","_id":"_meta","_version":1,"created":true"}

When I try to do the query:

curl localhost:9200/testdb/testdb/_search?pretty=1

{
"took" : 1,
"timed_out" : false,
"_shards" : {
"total" : 5,
"successful" : 5,
"failed" : 0
},
"hits" : {
"total" : 0,
"max_score" : null,
"hits" : [ ]
}
}

When I use the

curl http://localhost:9200/_search?q=*&pretty=true

{
"took" : 2,
"timed_out" : false,
"_shards" : {
"total" : 16,
"successful" : 16,
"failed" : 0
},
"hits" : {
"total" : 1,
"max_score" : 1.0,
"hits" : [ {
"_index" : "_river",
"_type" : "testdb",
"_id" : "_meta",
"_score" : "1.0",
"_source" : {"type" "couchdb", "couchdb" : {"host" : "localhost",
"port": "5984", "db" : "testdb", "filter" : null}}
} ]
}
}

On Wednesday, June 5, 2013 at 1:59:04 AM UTC-4, David Pilato wrote:

Just to double check, could you run:
http://localhost:9200/_search?q=*&pretty=true
http://localhost:9200/my_db/_search?q=*&pretty=true

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 5 juin 2013 à 00:19, Yannis Psarras yannis....@gmail.com a écrit :

And with the q=* I get the same really as above

(for query: http://localhost:9200/my_db/_search?q=*&pretty=true)

On Wed, Jun 5, 2013 at 1:17 AM, Yannis Psarras yannis....@gmail.com
wrote:

I get the following:

curl -XGET "http://localhost:9200/my_db/_search?pretty=true http://localhost:9200/my_db/my_db/_search?pretty=true"
{
"took" : 2,
"timed_out" : false,
"_shards" : {
"total" : 5,
"successful" : 5,
"failed" : 0
},
"hits" : {
"total" : 0,
"max_score" : null,
"hits" : [ ]
}
}

On Wed, Jun 5, 2013 at 12:53 AM, David Pilato da...@pilato.fr wrote:

Not sure that default type is dbname.
What do you get with:

curl -XGET "http://localhost:9200/my_db/_search?q=*&pretty=true"

?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 4 juin 2013 à 23:26, Yannis Psarras yannis....@gmail.com a écrit :

I recently started using elastic search and couchdb and I have the
following problem. I have a couch database with a bunch of documents. I add
a couch db river index on elastic search and I expect to have those
documents indexed and searchable. But when I search for anything through ES
I dont get any results. The command flow is as follows:

The command above verifies that there are 4 documents in the couch db
instance

curl -H "Content-Type: application/json" -X GET http://localhost:5984/my_db

{"db_name":"my_db","doc_count":4,"doc_del_count":0,"update_seq":4,"purge_seq":0,"compact_running":false,"disk_size":16482,"data_size":646,"instance_start_time":"1370204643908592","disk_format_version":6,"committed_update_seq":4}

The _changes output:

curl -H "Content-Type: application/json" -X GET http://localhost:5984/my_db/_changes
{"results":[
{"seq":1,"id":"1","changes":[{"rev":"1-40d928a959dd52d183ab7c413fabca92"}]},
{"seq":2,"id":"2","changes":[{"rev":"1-42212757a56b240f5205266b1969e890"}]},
{"seq":3,"id":"3","changes":[{"rev":"1-f59c2ae7acacb68d9414be05d56ed33a"}]},
{"seq":4,"id":"4","changes":[{"rev":"1-e86cf1c287c16906e81d901365b9bf98"}]}
],
"last_seq":4}

Now, below I m creating my index in ES.

curl -XPUT 'http://localhost:9200/_river/my_db/_meta' -d '{ "type" : "couchdb", "couchdb" : { "host" : "localhost", "port" : 5984, "db" : "my_db", "filter" : null } }'

{"ok":true,"_index":"_river","_type":"my_db","_id":"_meta","_version":1}

But I dont get anything back.

curl -XGET "http://localhost:9200/my_db/my_db/_search?pretty=true"
{
"took" : 2,
"timed_out" : false,
"_shards" : {
"total" : 5,
"successful" : 5,
"failed" : 0
},
"hits" : {
"total" : 0,
"max_score" : null,
"hits" : [ ]
}
}

Is there anything I m missing?

Thanks, Yannis

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/
topic/elasticsearch/FUJj2c4ycnc/unsubscribe?hl=en-US.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/acdd73d6-e67a-4246-9dd5-75e99c6ffc31%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/acdd73d6-e67a-4246-9dd5-75e99c6ffc31%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/FUJj2c4ycnc/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/F820A4DF-BC87-4C49-B3E2-2F8BC9ABDAD6%40pilato.fr
https://groups.google.com/d/msgid/elasticsearch/F820A4DF-BC87-4C49-B3E2-2F8BC9ABDAD6%40pilato.fr?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CABs-q54f5D--_CERLBoCEf7jH6M73HxnL78OkzQsu%3DZ_S65ouA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.

Anything in logs?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfr https://twitter.com/elasticsearchfr | @scrutmydocs https://twitter.com/scrutmydocs

Le 2 févr. 2015 à 17:04, Bao-Quan Ho ho.baoquan@gmail.com a écrit :

Hello I tried as suggested but I get the same outcome:

curl localhost:9200/testdb/_search?pretty=1

{
"took" : 1,
"timed_out" : false,
"_shards" : {
"total" : 5,
"successful" : 5,
"failed" : 0
},
"hits" : {
"total" : 0,
"max_score" : null,
"hits" : [ ]
}
}

On Mon, Feb 2, 2015 at 6:35 AM, David Pilato <david@pilato.fr mailto:david@pilato.fr> wrote:
Try with:

localhost:9200/testdb/_search

I think you are using the default type name here which is not IIRC the river name.

HTH

David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 2 févr. 2015 à 11:43, Bao-Quan Ho <ho.baoquan@gmail.com mailto:ho.baoquan@gmail.com> a écrit :

David,

Sorry for the old post revival, but I'm getting this same error with no hits with Couchdb rivers (2.4.1), Elasticsearch (1.4.2), and Couchdb (1.6.1). I am fairly new to using couch-rivers but I've installed all the applications and they are running on Centos 7. Can you please see if you notice anything wrong? I've looked everywhere but can not find a solution. Thank you in advance

I added some dummy data into my couchdb database "testdb":

curl -XGET localhost:5984/testdb/_changes

{"results":[
{"seq":1,"id":"1","changes":[{"rev":"1-0291....."}]},
{"seq":2,"id":"2","changes":[{"rev":"1-1945....."}]},
{"seq":3,"id":"3","changes":[{"rev":"1-62a5....."}]},
{"seq":4,"id":"4","changes":[{"rev":"1-7e93....."}]},
],
"last_seq":4}

I run this to make the index:

curl -X PUT 'http://localhost:9200/_river/testdb/_meta' http://localhost:9200/_river/testdb/_meta' -d '{ "type" : "couchdb", "couchdb" : { "host" : "localhost", "port" : 5984, "db" : "testdb", "filter" : null }"'

Get a return of:

{"index":"_river","_type":"testdb","_id":"_meta","_version":1,"created":true"}

When I try to do the query:

curl localhost:9200/testdb/testdb/_search?pretty=1

{
"took" : 1,
"timed_out" : false,
"_shards" : {
"total" : 5,
"successful" : 5,
"failed" : 0
},
"hits" : {
"total" : 0,
"max_score" : null,
"hits" : [ ]
}
}

When I use the

curl http://localhost:9200/_search?q=*&pretty=true http://localhost:9200/_search?q=*&pretty=true

{
"took" : 2,
"timed_out" : false,
"_shards" : {
"total" : 16,
"successful" : 16,
"failed" : 0
},
"hits" : {
"total" : 1,
"max_score" : 1.0,
"hits" : [ {
"_index" : "_river",
"_type" : "testdb",
"_id" : "_meta",
"_score" : "1.0",
"_source" : {"type" "couchdb", "couchdb" : {"host" : "localhost", "port": "5984", "db" : "testdb", "filter" : null}}
} ]
}
}

On Wednesday, June 5, 2013 at 1:59:04 AM UTC-4, David Pilato wrote:
Just to double check, could you run:
http://localhost:9200/_search?q=*&pretty=true http://localhost:9200/my_db/_search?q=*&pretty=true

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 5 juin 2013 à 00:19, Yannis Psarras <yannis....@gmail.com <>> a écrit :

And with the q=* I get the same really as above

(for query: http://localhost:9200/my_db/_search?q=*&pretty=true http://localhost:9200/my_db/_search?q=*&pretty=true)

On Wed, Jun 5, 2013 at 1:17 AM, Yannis Psarras <yannis....@gmail.com <>> wrote:
I get the following:

curl -XGET "http://localhost:9200/my_db/_search?pretty=true http://localhost:9200/my_db/my_db/_search?pretty=true"
{
"took" : 2,
"timed_out" : false,
"_shards" : {
"total" : 5,
"successful" : 5,
"failed" : 0
},
"hits" : {
"total" : 0,
"max_score" : null,
"hits" : [ ]
}
}

On Wed, Jun 5, 2013 at 12:53 AM, David Pilato <da...@pilato.fr <>> wrote:
Not sure that default type is dbname.
What do you get with:
curl -XGET "http://localhost:9200/my_db/_search?q=*&pretty=true http://localhost:9200/my_db/_search?q=*&pretty=true"
?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 4 juin 2013 à 23:26, Yannis Psarras <yannis....@gmail.com <>> a écrit :

I recently started using elastic search and couchdb and I have the following problem. I have a couch database with a bunch of documents. I add a couch db river index on elastic search and I expect to have those documents indexed and searchable. But when I search for anything through ES I dont get any results. The command flow is as follows:

The command above verifies that there are 4 documents in the couch db instance

curl -H "Content-Type: application/json" -X GET http://localhost:5984/my_db http://localhost:5984/my_db

{"db_name":"my_db","doc_count":4,"doc_del_count":0,"update_seq":4,"purge_seq":0,"compact_running":false,"disk_size":16482,"data_size":646,"instance_start_time":"1370204643908592","disk_format_version":6,"committed_update_seq":4}
The _changes output:

curl -H "Content-Type: application/json" -X GET http://localhost:5984/my_db/_changes http://localhost:5984/my_db/_changes
{"results":[
{"seq":1,"id":"1","changes":[{"rev":"1-40d928a959dd52d183ab7c413fabca92"}]},
{"seq":2,"id":"2","changes":[{"rev":"1-42212757a56b240f5205266b1969e890"}]},
{"seq":3,"id":"3","changes":[{"rev":"1-f59c2ae7acacb68d9414be05d56ed33a"}]},
{"seq":4,"id":"4","changes":[{"rev":"1-e86cf1c287c16906e81d901365b9bf98"}]}
],
"last_seq":4}
Now, below I m creating my index in ES.

curl -XPUT 'http://localhost:9200/_river/my_db/_meta' http://localhost:9200/_river/my_db/_meta' -d '{ "type" : "couchdb", "couchdb" : { "host" : "localhost", "port" : 5984, "db" : "my_db", "filter" : null } }'

{"ok":true,"_index":"_river","_type":"my_db","_id":"_meta","_version":1}
But I dont get anything back.

curl -XGET "http://localhost:9200/my_db/my_db/_search?pretty=true http://localhost:9200/my_db/my_db/_search?pretty=true"
{
"took" : 2,
"timed_out" : false,
"_shards" : {
"total" : 5,
"successful" : 5,
"failed" : 0
},
"hits" : {
"total" : 0,
"max_score" : null,
"hits" : [ ]
}
}
Is there anything I m missing?

Thanks, Yannis

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com <>.

For more options, visit https://groups.google.com/groups/opt_out https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/elasticsearch/FUJj2c4ycnc/unsubscribe?hl=en-US https://groups.google.com/d/topic/elasticsearch/FUJj2c4ycnc/unsubscribe?hl=en-US.
To unsubscribe from this group and all its topics, send an email to elasticsearc...@googlegroups.com <>.
For more options, visit https://groups.google.com/groups/opt_out https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com <>.
For more options, visit https://groups.google.com/groups/opt_out https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com mailto:elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/acdd73d6-e67a-4246-9dd5-75e99c6ffc31%40googlegroups.com https://groups.google.com/d/msgid/elasticsearch/acdd73d6-e67a-4246-9dd5-75e99c6ffc31%40googlegroups.com?utm_medium=email&utm_source=footer.
For more options, visit https://groups.google.com/d/optout https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/elasticsearch/FUJj2c4ycnc/unsubscribe https://groups.google.com/d/topic/elasticsearch/FUJj2c4ycnc/unsubscribe.
To unsubscribe from this group and all its topics, send an email to elasticsearch+unsubscribe@googlegroups.com mailto:elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/F820A4DF-BC87-4C49-B3E2-2F8BC9ABDAD6%40pilato.fr https://groups.google.com/d/msgid/elasticsearch/F820A4DF-BC87-4C49-B3E2-2F8BC9ABDAD6%40pilato.fr?utm_medium=email&utm_source=footer.

For more options, visit https://groups.google.com/d/optout https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com mailto:elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CABs-q54f5D--_CERLBoCEf7jH6M73HxnL78OkzQsu%3DZ_S65ouA%40mail.gmail.com https://groups.google.com/d/msgid/elasticsearch/CABs-q54f5D--_CERLBoCEf7jH6M73HxnL78OkzQsu%3DZ_S65ouA%40mail.gmail.com?utm_medium=email&utm_source=footer.
For more options, visit https://groups.google.com/d/optout https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/45CACB8D-75EA-4FD0-BD73-6CDA32488EFE%40pilato.fr.
For more options, visit https://groups.google.com/d/optout.

Hello I tried as suggested but I get the same outcome:

curl localhost:9200/testdb/_search?pretty=1

{
"took" : 1,
"timed_out" : false,
"_shards" : {
"total" : 5,
"successful" : 5,
"failed" : 0
},
"hits" : {
"total" : 0,
"max_score" : null,
"hits" : [ ]
}
}

On Monday, February 2, 2015 at 6:35:59 AM UTC-5, David Pilato wrote:

Try with:

localhost:9200/testdb/_search

I think you are using the default type name here which is not IIRC the
river name.

HTH

David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 2 févr. 2015 à 11:43, Bao-Quan Ho <ho.ba...@gmail.com <javascript:>> a
écrit :

David,

Sorry for the old post revival, but I'm getting this same error with no
hits with Couchdb rivers (2.4.1), Elasticsearch (1.4.2), and Couchdb
(1.6.1). I am fairly new to using couch-rivers but I've installed all the
applications and they are running on Centos 7. Can you please see if you
notice anything wrong? I've looked everywhere but can not find a solution.
Thank you in advance

I added some dummy data into my couchdb database "testdb":

curl -XGET localhost:5984/testdb/_changes

{"results":[
{"seq":1,"id":"1","changes":[{"rev":"1-0291....."}]},
{"seq":2,"id":"2","changes":[{"rev":"1-1945....."}]},
{"seq":3,"id":"3","changes":[{"rev":"1-62a5....."}]},
{"seq":4,"id":"4","changes":[{"rev":"1-7e93....."}]},
],
"last_seq":4}

I run this to make the index:

curl -X PUT 'http://localhost:9200/_river/testdb/_meta' -d '{ "type" :

"couchdb", "couchdb" : { "host" : "localhost", "port" : 5984, "db" :
"testdb", "filter" : null }"'

Get a return of:

{"index":"_river","_type":"testdb","_id":"_meta","_version":1,"created":true"}

When I try to do the query:

curl localhost:9200/testdb/testdb/_search?pretty=1

{
"took" : 1,
"timed_out" : false,
"_shards" : {
"total" : 5,
"successful" : 5,
"failed" : 0
},
"hits" : {
"total" : 0,
"max_score" : null,
"hits" : [ ]
}
}

When I use the

curl http://localhost:9200/_search?q=*&pretty=true

{
"took" : 2,
"timed_out" : false,
"_shards" : {
"total" : 16,
"successful" : 16,
"failed" : 0
},
"hits" : {
"total" : 1,
"max_score" : 1.0,
"hits" : [ {
"_index" : "_river",
"_type" : "testdb",
"_id" : "_meta",
"_score" : "1.0",
"_source" : {"type" "couchdb", "couchdb" : {"host" : "localhost",
"port": "5984", "db" : "testdb", "filter" : null}}
} ]
}
}

On Wednesday, June 5, 2013 at 1:59:04 AM UTC-4, David Pilato wrote:

Just to double check, could you run:
http://localhost:9200/_search?q=*&pretty=true
http://localhost:9200/my_db/_search?q=*&pretty=true

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 5 juin 2013 à 00:19, Yannis Psarras yannis....@gmail.com a écrit :

And with the q=* I get the same really as above

(for query: http://localhost:9200/my_db/_search?q=*&pretty=true)

On Wed, Jun 5, 2013 at 1:17 AM, Yannis Psarras yannis....@gmail.com
wrote:

I get the following:

curl -XGET "http://localhost:9200/my_db/_search?pretty=true http://localhost:9200/my_db/my_db/_search?pretty=true"
{
"took" : 2,
"timed_out" : false,
"_shards" : {
"total" : 5,
"successful" : 5,
"failed" : 0
},
"hits" : {
"total" : 0,
"max_score" : null,
"hits" : [ ]
}
}

On Wed, Jun 5, 2013 at 12:53 AM, David Pilato da...@pilato.fr wrote:

Not sure that default type is dbname.
What do you get with:

curl -XGET "http://localhost:9200/my_db/_search?q=*&pretty=true"

?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 4 juin 2013 à 23:26, Yannis Psarras yannis....@gmail.com a écrit :

I recently started using elastic search and couchdb and I have the
following problem. I have a couch database with a bunch of documents. I add
a couch db river index on elastic search and I expect to have those
documents indexed and searchable. But when I search for anything through ES
I dont get any results. The command flow is as follows:

The command above verifies that there are 4 documents in the couch db
instance

curl -H "Content-Type: application/json" -X GET http://localhost:5984/my_db

{"db_name":"my_db","doc_count":4,"doc_del_count":0,"update_seq":4,"purge_seq":0,"compact_running":false,"disk_size":16482,"data_size":646,"instance_start_time":"1370204643908592","disk_format_version":6,"committed_update_seq":4}

The _changes output:

curl -H "Content-Type: application/json" -X GET http://localhost:5984/my_db/_changes
{"results":[
{"seq":1,"id":"1","changes":[{"rev":"1-40d928a959dd52d183ab7c413fabca92"}]},
{"seq":2,"id":"2","changes":[{"rev":"1-42212757a56b240f5205266b1969e890"}]},
{"seq":3,"id":"3","changes":[{"rev":"1-f59c2ae7acacb68d9414be05d56ed33a"}]},
{"seq":4,"id":"4","changes":[{"rev":"1-e86cf1c287c16906e81d901365b9bf98"}]}
],
"last_seq":4}

Now, below I m creating my index in ES.

curl -XPUT 'http://localhost:9200/_river/my_db/_meta' -d '{ "type" : "couchdb", "couchdb" : { "host" : "localhost", "port" : 5984, "db" : "my_db", "filter" : null } }'

{"ok":true,"_index":"_river","_type":"my_db","_id":"_meta","_version":1}

But I dont get anything back.

curl -XGET "http://localhost:9200/my_db/my_db/_search?pretty=true"
{
"took" : 2,
"timed_out" : false,
"_shards" : {
"total" : 5,
"successful" : 5,
"failed" : 0
},
"hits" : {
"total" : 0,
"max_score" : null,
"hits" : [ ]
}
}

Is there anything I m missing?

Thanks, Yannis

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/FUJj2c4ycnc/unsubscribe?hl=en-US
.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/acdd73d6-e67a-4246-9dd5-75e99c6ffc31%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/acdd73d6-e67a-4246-9dd5-75e99c6ffc31%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/fe2fb07a-3d72-4189-88fe-0beb50ebe76a%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

looking in /vars/log/elasticsearch/elasticsearch.log
[2015-02-02 10:42:31,415][INFO ][river.couchdb ][Matt Murdock][couchdb][
testdb] starting couchdb stream: host [localhost], port [5984], filter [null
], db [testdb], indexing to [testdb]/[testdb]

On Monday, February 2, 2015 at 11:05:53 AM UTC-5, David Pilato wrote:

Anything in logs?

--
David Pilato | Technical Advocate | Elasticsearch.com
http://Elasticsearch.com

@dadoonet https://twitter.com/dadoonet | @elasticsearchfr
https://twitter.com/elasticsearchfr | @scrutmydocs
https://twitter.com/scrutmydocs

Le 2 févr. 2015 à 17:04, Bao-Quan Ho <ho.ba...@gmail.com <javascript:>> a
écrit :

Hello I tried as suggested but I get the same outcome:

curl localhost:9200/testdb/_search?pretty=1

{
"took" : 1,
"timed_out" : false,
"_shards" : {
"total" : 5,
"successful" : 5,
"failed" : 0
},
"hits" : {
"total" : 0,
"max_score" : null,
"hits" : [ ]
}
}

On Mon, Feb 2, 2015 at 6:35 AM, David Pilato <da...@pilato.fr
<javascript:>> wrote:

Try with:

localhost:9200/testdb/_search

I think you are using the default type name here which is not IIRC the
river name.

HTH

David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 2 févr. 2015 à 11:43, Bao-Quan Ho <ho.ba...@gmail.com <javascript:>> a
écrit :

David,

Sorry for the old post revival, but I'm getting this same error with no
hits with Couchdb rivers (2.4.1), Elasticsearch (1.4.2), and Couchdb
(1.6.1). I am fairly new to using couch-rivers but I've installed all the
applications and they are running on Centos 7. Can you please see if you
notice anything wrong? I've looked everywhere but can not find a
solution. Thank you in advance

I added some dummy data into my couchdb database "testdb":

curl -XGET localhost:5984/testdb/_changes

{"results":[
{"seq":1,"id":"1","changes":[{"rev":"1-0291....."}]},
{"seq":2,"id":"2","changes":[{"rev":"1-1945....."}]},
{"seq":3,"id":"3","changes":[{"rev":"1-62a5....."}]},
{"seq":4,"id":"4","changes":[{"rev":"1-7e93....."}]},
],
"last_seq":4}

I run this to make the index:

curl -X PUT 'http://localhost:9200/_river/testdb/_meta' -d '{ "type" :

"couchdb", "couchdb" : { "host" : "localhost", "port" : 5984, "db" :
"testdb", "filter" : null }"'

Get a return of:

{"index":"_river","_type":"testdb","_id":"_meta","_version":1,"created":true"}

When I try to do the query:

curl localhost:9200/testdb/testdb/_search?pretty=1

{
"took" : 1,
"timed_out" : false,
"_shards" : {
"total" : 5,
"successful" : 5,
"failed" : 0
},
"hits" : {
"total" : 0,
"max_score" : null,
"hits" : [ ]
}
}

When I use the

curl http://localhost:9200/_search?q=*&pretty=true

{
"took" : 2,
"timed_out" : false,
"_shards" : {
"total" : 16,
"successful" : 16,
"failed" : 0
},
"hits" : {
"total" : 1,
"max_score" : 1.0,
"hits" : [ {
"_index" : "_river",
"_type" : "testdb",
"_id" : "_meta",
"_score" : "1.0",
"_source" : {"type" "couchdb", "couchdb" : {"host" : "localhost",
"port": "5984", "db" : "testdb", "filter" : null}}
} ]
}
}

On Wednesday, June 5, 2013 at 1:59:04 AM UTC-4, David Pilato wrote:

Just to double check, could you run:
http://localhost:9200/_search?q=*&pretty=true
http://localhost:9200/my_db/_search?q=*&pretty=true

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 5 juin 2013 à 00:19, Yannis Psarras yannis....@gmail.com a écrit :

And with the q=* I get the same really as above

(for query: http://localhost:9200/my_db/_search?q=*&pretty=true)

On Wed, Jun 5, 2013 at 1:17 AM, Yannis Psarras yannis....@gmail.com
wrote:

I get the following:

curl -XGET "http://localhost:9200/my_db/_search?pretty=true http://localhost:9200/my_db/my_db/_search?pretty=true"
{
"took" : 2,
"timed_out" : false,
"_shards" : {
"total" : 5,
"successful" : 5,
"failed" : 0
},
"hits" : {
"total" : 0,
"max_score" : null,
"hits" : [ ]
}
}

On Wed, Jun 5, 2013 at 12:53 AM, David Pilato da...@pilato.fr wrote:

Not sure that default type is dbname.
What do you get with:

curl -XGET "http://localhost:9200/my_db/_search?q=*&pretty=true"

?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 4 juin 2013 à 23:26, Yannis Psarras yannis....@gmail.com a écrit :

I recently started using elastic search and couchdb and I have the
following problem. I have a couch database with a bunch of documents. I add
a couch db river index on elastic search and I expect to have those
documents indexed and searchable. But when I search for anything through ES
I dont get any results. The command flow is as follows:

The command above verifies that there are 4 documents in the couch db
instance

curl -H "Content-Type: application/json" -X GET http://localhost:5984/my_db

{"db_name":"my_db","doc_count":4,"doc_del_count":0,"update_seq":4,"purge_seq":0,"compact_running":false,"disk_size":16482,"data_size":646,"instance_start_time":"1370204643908592","disk_format_version":6,"committed_update_seq":4}

The _changes output:

curl -H "Content-Type: application/json" -X GET http://localhost:5984/my_db/_changes
{"results":[
{"seq":1,"id":"1","changes":[{"rev":"1-40d928a959dd52d183ab7c413fabca92"}]},
{"seq":2,"id":"2","changes":[{"rev":"1-42212757a56b240f5205266b1969e890"}]},
{"seq":3,"id":"3","changes":[{"rev":"1-f59c2ae7acacb68d9414be05d56ed33a"}]},
{"seq":4,"id":"4","changes":[{"rev":"1-e86cf1c287c16906e81d901365b9bf98"}]}
],
"last_seq":4}

Now, below I m creating my index in ES.

curl -XPUT 'http://localhost:9200/_river/my_db/_meta' -d '{ "type" : "couchdb", "couchdb" : { "host" : "localhost", "port" : 5984, "db" : "my_db", "filter" : null } }'

{"ok":true,"_index":"_river","_type":"my_db","_id":"_meta","_version":1}

But I dont get anything back.

curl -XGET "http://localhost:9200/my_db/my_db/_search?pretty=true"
{
"took" : 2,
"timed_out" : false,
"_shards" : {
"total" : 5,
"successful" : 5,
"failed" : 0
},
"hits" : {
"total" : 0,
"max_score" : null,
"hits" : [ ]
}
}

Is there anything I m missing?

Thanks, Yannis

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/
topic/elasticsearch/FUJj2c4ycnc/unsubscribe?hl=en-US.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com.
For more options, visit

...

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/18309d8a-9476-4d31-a79b-d44f79d79b38%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

So you should try to change logs to DEBUG or TRACE and see what it tells.

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfr https://twitter.com/elasticsearchfr | @scrutmydocs https://twitter.com/scrutmydocs

Le 2 févr. 2015 à 17:20, Bao-Quan Ho ho.baoquan@gmail.com a écrit :

looking in /vars/log/elasticsearch/elasticsearch.log
[2015-02-02 10:42:31,415][INFO ][river.couchdb ][Matt Murdock][couchdb][testdb] starting couchdb stream: host [localhost], port [5984], filter [null], db [testdb], indexing to [testdb]/[testdb]

On Monday, February 2, 2015 at 11:05:53 AM UTC-5, David Pilato wrote:
Anything in logs?

--
David Pilato | Technical Advocate | Elasticsearch.com http://elasticsearch.com/
@dadoonet https://twitter.com/dadoonet | @elasticsearchfr https://twitter.com/elasticsearchfr | @scrutmydocs https://twitter.com/scrutmydocs

Le 2 févr. 2015 à 17:04, Bao-Quan Ho <ho.ba...@gmail.com <javascript:>> a écrit :

Hello I tried as suggested but I get the same outcome:

curl localhost:9200/testdb/_search?pretty=1

{
"took" : 1,
"timed_out" : false,
"_shards" : {
"total" : 5,
"successful" : 5,
"failed" : 0
},
"hits" : {
"total" : 0,
"max_score" : null,
"hits" : [ ]
}
}

On Mon, Feb 2, 2015 at 6:35 AM, David Pilato <da...@pilato.fr <javascript:>> wrote:
Try with:

localhost:9200/testdb/_search

I think you are using the default type name here which is not IIRC the river name.

HTH

David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 2 févr. 2015 à 11:43, Bao-Quan Ho <ho.ba...@gmail.com <javascript:>> a écrit :

David,

Sorry for the old post revival, but I'm getting this same error with no hits with Couchdb rivers (2.4.1), Elasticsearch (1.4.2), and Couchdb (1.6.1). I am fairly new to using couch-rivers but I've installed all the applications and they are running on Centos 7. Can you please see if you notice anything wrong? I've looked everywhere but can not find a solution. Thank you in advance

I added some dummy data into my couchdb database "testdb":

curl -XGET localhost:5984/testdb/_changes

{"results":[
{"seq":1,"id":"1","changes":[{"rev":"1-0291....."}]},
{"seq":2,"id":"2","changes":[{"rev":"1-1945....."}]},
{"seq":3,"id":"3","changes":[{"rev":"1-62a5....."}]},
{"seq":4,"id":"4","changes":[{"rev":"1-7e93....."}]},
],
"last_seq":4}

I run this to make the index:

curl -X PUT 'http://localhost:9200/_river/testdb/_meta' http://localhost:9200/_river/testdb/_meta' -d '{ "type" : "couchdb", "couchdb" : { "host" : "localhost", "port" : 5984, "db" : "testdb", "filter" : null }"'

Get a return of:

{"index":"_river","_type":"testdb","_id":"_meta","_version":1,"created":true"}

When I try to do the query:

curl localhost:9200/testdb/testdb/_search?pretty=1

{
"took" : 1,
"timed_out" : false,
"_shards" : {
"total" : 5,
"successful" : 5,
"failed" : 0
},
"hits" : {
"total" : 0,
"max_score" : null,
"hits" : [ ]
}
}

When I use the

curl http://localhost:9200/_search?q=*&pretty=true http://localhost:9200/_search?q=*&pretty=true

{
"took" : 2,
"timed_out" : false,
"_shards" : {
"total" : 16,
"successful" : 16,
"failed" : 0
},
"hits" : {
"total" : 1,
"max_score" : 1.0,
"hits" : [ {
"_index" : "_river",
"_type" : "testdb",
"_id" : "_meta",
"_score" : "1.0",
"_source" : {"type" "couchdb", "couchdb" : {"host" : "localhost", "port": "5984", "db" : "testdb", "filter" : null}}
} ]
}
}

On Wednesday, June 5, 2013 at 1:59:04 AM UTC-4, David Pilato wrote:
Just to double check, could you run:
http://localhost:9200/_search?q=*&pretty=true http://localhost:9200/my_db/_search?q=*&pretty=true

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 5 juin 2013 à 00:19, Yannis Psarras <yannis....@gmail.com <>> a écrit :

And with the q=* I get the same really as above

(for query: http://localhost:9200/my_db/_search?q=*&pretty=true http://localhost:9200/my_db/_search?q=*&pretty=true)

On Wed, Jun 5, 2013 at 1:17 AM, Yannis Psarras <yannis....@gmail.com <>> wrote:
I get the following:

curl -XGET "http://localhost:9200/my_db/_search?pretty=true http://localhost:9200/my_db/my_db/_search?pretty=true"
{
"took" : 2,
"timed_out" : false,
"_shards" : {
"total" : 5,
"successful" : 5,
"failed" : 0
},
"hits" : {
"total" : 0,
"max_score" : null,
"hits" : [ ]
}
}

On Wed, Jun 5, 2013 at 12:53 AM, David Pilato <da...@pilato.fr <>> wrote:
Not sure that default type is dbname.
What do you get with:
curl -XGET "http://localhost:9200/my_db/_search?q=*&pretty=true http://localhost:9200/my_db/_search?q=*&pretty=true"
?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 4 juin 2013 à 23:26, Yannis Psarras <yannis....@gmail.com <>> a écrit :

I recently started using elastic search and couchdb and I have the following problem. I have a couch database with a bunch of documents. I add a couch db river index on elastic search and I expect to have those documents indexed and searchable. But when I search for anything through ES I dont get any results. The command flow is as follows:

The command above verifies that there are 4 documents in the couch db instance

curl -H "Content-Type: application/json" -X GET http://localhost:5984/my_db http://localhost:5984/my_db

{"db_name":"my_db","doc_count":4,"doc_del_count":0,"update_seq":4,"purge_seq":0,"compact_running":false,"disk_size":16482,"data_size":646,"instance_start_time":"1370204643908592","disk_format_version":6,"committed_update_seq":4}
The _changes output:

curl -H "Content-Type: application/json" -X GET http://localhost:5984/my_db/_changes http://localhost:5984/my_db/_changes
{"results":[
{"seq":1,"id":"1","changes":[{"rev":"1-40d928a959dd52d183ab7c413fabca92"}]},
{"seq":2,"id":"2","changes":[{"rev":"1-42212757a56b240f5205266b1969e890"}]},
{"seq":3,"id":"3","changes":[{"rev":"1-f59c2ae7acacb68d9414be05d56ed33a"}]},
{"seq":4,"id":"4","changes":[{"rev":"1-e86cf1c287c16906e81d901365b9bf98"}]}
],
"last_seq":4}
Now, below I m creating my index in ES.

curl -XPUT 'http://localhost:9200/_river/my_db/_meta' http://localhost:9200/_river/my_db/_meta' -d '{ "type" : "couchdb", "couchdb" : { "host" : "localhost", "port" : 5984, "db" : "my_db", "filter" : null } }'

{"ok":true,"_index":"_river","_type":"my_db","_id":"_meta","_version":1}
But I dont get anything back.

curl -XGET "http://localhost:9200/my_db/my_db/_search?pretty=true http://localhost:9200/my_db/my_db/_search?pretty=true"
{
"took" : 2,
"timed_out" : false,
"_shards" : {
"total" : 5,
"successful" : 5,
"failed" : 0
},
"hits" : {
"total" : 0,
"max_score" : null,
"hits" : [ ]
}
}
Is there anything I m missing?

Thanks, Yannis

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com <>.

For more options, visit https://groups.google.com/groups/opt_out https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/elasticsearch/FUJj2c4ycnc/unsubscribe?hl=en-US https://groups.google.com/d/topic/elasticsearch/FUJj2c4ycnc/unsubscribe?hl=en-US.
To unsubscribe from this group and all its topics, send an email to elasticsearc...@googlegroups.com <>.
For more options, visit https://groups.google.com/groups/opt_out https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com <>.
For more options, visit
...

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com mailto:elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/18309d8a-9476-4d31-a79b-d44f79d79b38%40googlegroups.com https://groups.google.com/d/msgid/elasticsearch/18309d8a-9476-4d31-a79b-d44f79d79b38%40googlegroups.com?utm_medium=email&utm_source=footer.
For more options, visit https://groups.google.com/d/optout https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/F6E9ADE7-E0F2-42E4-9630-AD5B59AA0921%40pilato.fr.
For more options, visit https://groups.google.com/d/optout.

Sorry about that David. After setting to DEBUG, I don't anything that's
showing an error. I did a grep for "testdb" and only found a lot of (I
also did look at the raw log and did not see any errors):

Elasticsearch.log:
[Crime-Buster][testdb]state: [POST_RECOVERY]->[STARTED], reason [global
state is [STARTED]]
[Crime-Buster][testdb]processing [shard-started ([testdb][4]
node[60hasdfadsf...].[P],s[INITIALIZING]), reason [after recovery from
gateway]]: done applying updated cluster_state
[Crime-Buster][testdb] updating index_buffer size from [64mb] to [6.3mb]

A side note, since I'm more accustomed to Windows OS. I took the time to
install all the same application versions as above and I was able to do a
query.

One thing I did notice when I did a query on Windows 7, the index [testdb]
was not found and I had to do a

curl -XPUT localhost:9200/testdb

then I did

curl localhost:9200/testdb/testdb/_search , which is pulling the data

from couchdb correctly. But again this was all working on Windows 7 OS but
I can't get this working on Centos.

Do you happen to know if there is a issue using Centos 7 RHEL that may not
allow the query to go through?

On Monday, February 2, 2015 at 11:54:53 AM UTC-5, David Pilato wrote:

So you should try to change logs to DEBUG or TRACE and see what it tells.

--
David Pilato | Technical Advocate | Elasticsearch.com
http://Elasticsearch.com

@dadoonet https://twitter.com/dadoonet | @elasticsearchfr
https://twitter.com/elasticsearchfr | @scrutmydocs
https://twitter.com/scrutmydocs

Le 2 févr. 2015 à 17:20, Bao-Quan Ho <ho.ba...@gmail.com <javascript:>> a
écrit :

looking in /vars/log/elasticsearch/elasticsearch.log
[2015-02-02 10:42:31,415][INFO ][river.couchdb ][Matt Murdock][couchdb][
testdb] starting couchdb stream: host [localhost], port [5984], filter [
null], db [testdb], indexing to [testdb]/[testdb]

On Monday, February 2, 2015 at 11:05:53 AM UTC-5, David Pilato wrote:

Anything in logs?

--
David Pilato | Technical Advocate | Elasticsearch.com
http://elasticsearch.com/

@dadoonet https://twitter.com/dadoonet | @elasticsearchfr
https://twitter.com/elasticsearchfr | @scrutmydocs
https://twitter.com/scrutmydocs

Le 2 févr. 2015 à 17:04, Bao-Quan Ho ho.ba...@gmail.com a écrit :

Hello I tried as suggested but I get the same outcome:

curl localhost:9200/testdb/_search?pretty=1

{
"took" : 1,
"timed_out" : false,
"_shards" : {
"total" : 5,
"successful" : 5,
"failed" : 0
},
"hits" : {
"total" : 0,
"max_score" : null,
"hits" : [ ]
}
}

On Mon, Feb 2, 2015 at 6:35 AM, David Pilato da...@pilato.fr wrote:

Try with:

localhost:9200/testdb/_search

I think you are using the default type name here which is not IIRC the
river name.

HTH

David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 2 févr. 2015 à 11:43, Bao-Quan Ho ho.ba...@gmail.com a écrit :

David,

Sorry for the old post revival, but I'm getting this same error with no
hits with Couchdb rivers (2.4.1), Elasticsearch (1.4.2), and Couchdb
(1.6.1). I am fairly new to using couch-rivers but I've installed all the
applications and they are running on Centos 7. Can you please see if you
notice anything wrong? I've looked everywhere but can not find a
solution. Thank you in advance

I added some dummy data into my couchdb database "testdb":

curl -XGET localhost:5984/testdb/_changes

{"results":[
{"seq":1,"id":"1","changes":[{"rev":"1-0291....."}]},
{"seq":2,"id":"2","changes":[{"rev":"1-1945....."}]},
{"seq":3,"id":"3","changes":[{"rev":"1-62a5....."}]},
{"seq":4,"id":"4","changes":[{"rev":"1-7e93....."}]},
],
"last_seq":4}

I run this to make the index:

curl -X PUT 'http://localhost:9200/_river/testdb/_meta' -d '{ "type" :

"couchdb", "couchdb" : { "host" : "localhost", "port" : 5984, "db" :
"testdb", "filter" : null }"'

Get a return of:

{"index":"_river","_type":"testdb","_id":"_meta","_version":1,"created":true"}

When I try to do the query:

curl localhost:9200/testdb/testdb/_search?pretty=1

{
"took" : 1,
"timed_out" : false,
"_shards" : {
"total" : 5,
"successful" : 5,
"failed" : 0
},
"hits" : {
"total" : 0,
"max_score" : null,
"hits" : [ ]
}
}

When I use the

curl http://localhost:9200/_search?q=*&pretty=true

{
"took" : 2,
"timed_out" : false,
"_shards" : {
"total" : 16,
"successful" : 16,
"failed" : 0
},
"hits" : {
"total" : 1,
"max_score" : 1.0,
"hits" : [ {
"_index" : "_river",
"_type" : "testdb",
"_id" : "_meta",
"_score" : "1.0",
"_source" : {"type" "couchdb", "couchdb" : {"host" : "localhost",
"port": "5984", "db" : "testdb", "filter" : null}}
} ]
}
}

On Wednesday, June 5, 2013 at 1:59:04 AM UTC-4, David Pilato wrote:

Just to double check, could you run:
http://localhost:9200/_search?q=*&pretty=true
http://localhost:9200/my_db/_search?q=*&pretty=true

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 5 juin 2013 à 00:19, Yannis Psarras yannis....@gmail.com a écrit :

And with the q=* I get the same really as above

(for query: http://localhost:9200/my_db/_search?q=*&pretty=true)

On Wed, Jun 5, 2013 at 1:17 AM, Yannis Psarras yannis....@gmail.com
wrote:

I get the following:

curl -XGET "

...

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/ea842b9f-35ac-4350-ae77-0a4d9f25a6e3%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.