Elastic Stack 5.5 Security update


(Josh Bressers) #1

Elasticsearch X-Pack Security user credentials disclosure (ESA-2017-10)

Elasticsearch X-Pack Security versions 5.0.0 to 5.4.3, when enabled, can result in the Elasticsearch _nodes API leaking sensitive configuration information, such as the paths and passphrases of SSL keys that were configured as part of an authentication realm. This could allow an authenticated Elasticsearch user to improperly view these details.

Affected versions
Elasticsearch X-Pack security versions 5.0.0 to 5.4.3

Solution and Mitigations
All users of X-Pack security should upgrade to version 5.5.0. This update will prevent the _nodes API from returning sensitive settings. If you cannot upgrade any sensitive settings can be hidden by using the X-Pack hide_settings configuration option

CVE ID: CVE-2017-8442