Elastic Stack 7.4.1 security update

Logstash Beats input denial of service flaw (ESA-2019-14)
A denial of service flaw was found in the Logstash beats input plugin. An unauthenticated user who is able to connect to the port the Logstash beats input could send a specially crafted network packet that would cause Logstash to stop responding.

If you are not using the Beats input plugin with Logstash you are not vulnerable to this issue.

Thanks to Dennis Detering, IT security consultant at Spike Reply for reporting this issue.

Affected Versions
Logstash versions before 7.4.1 and 6.8.4

Solutions and Mitigations:
Users should upgrade to Logstash version 7.4.1 or 6.8.4.

CVSSv3: 7.5 - AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVE ID: CVE-2019-7620