Elastic-webhook-service not found


My elastic web hook service does not seem to work.

I followed the guide for installing elk via operator using this guide: https://www.elastic.co/guide/en/cloud-on-k8s/current/k8s-quickstart.html

But I have been so stupid to do the following.

I downloaded the custom resource definitions and changed the image docker.elastic.co/eck/eck-operator:0.8.1 to docker.elastic.co/eck/eck-operator:0.9.0-rc2 and tried to deploy elasticsearch which kind of worked.

However, when I tried to delete elasticsearch using kubectl delete -f ... I noticed that nothing changed. So I deleted the secrets and services manually.

I changed the image back to 0.8.1 and tried to add the custom resources again, but i get this now:
Error from server (InternalError): error when creating "custom-resource-definition.elastic-system.yml": Internal error occurred: failed calling webhook "validation.license.elastic.co": Post https://elastic-webhook-service.elastic-system.svc:443/validate-secrets?timeout=30s: service "elastic-webhook-service" not found

Any help to fix this mess I created would be endlessly appreciated!

Is the operator up and running successfully? If not, it looks like you might have the admission webhook still defined, but the operator (which services the webhook) does not exist. You can confirm its existence with
kubectl get validatingwebhookconfigurations.admissionregistration.k8s.io
and you should see one named validating-webhook-configuration. If so you can delete it, redeploy the operator, and the webhook will be re-created when the new operator is deployed. Hope this helps

Thanks for the quick response! I installed the complete k8s cluster again so I can no longer confirm your solution.

In my search for a solution I did look into this file though and it was the case that the web hook was defined there while I suspected it was no longer served. But since a few other entries where defined there I was afraid that I would break more than I would fix. For what its worth...

Anyway, thanks again!

Got it, thanks for following up. We've made some changes that will be in the next release that should resolve that particular issue (if that was indeed the root cause for you).