Elastichsearch not_analyzed issue

Dear All,
I experiencing issue on not_analyzed. I had manually create my mapping with


Called_Station_Id is a mac address (20-82-C0-DD-7E-9D )

I can see it not not_analyzed too under kibana Index Patterns, however it still not be able to do with

ElasticSearch : 2.3.0
Kibana : 4.5.0

Please advice me.
Thank You


I was unable to extract your exact problem in your question. Can you please take some more time and write up, what is not working as expected? Preferrably with examples (index creation, document creation, sample query, full mapping). Thanks!


Hi Sir,

I had figure what the caused of my trouble. My question is : although i set my field to "not_analyzed", but it actually still with "analyzed" when i do query with elasticsearch.

What i found is that, i have wrong setting for my index & template. After I update my _template then everythings work well.

Thank You.

Great to hear it works!

FYI: Updating your template will not update your index, but only if you create a new index. Also you cannot change a mapping from analyzed to not_analyzed once it has been created.


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.