Elasticseach is not matching ”_id” between the clusters

I have two Web Servers ws001 and ws002 working as load balance for
Elasticseach and I am trying to catch/count the hits for a specific page
which is something like this: mysite.com/listing/item-123/.

Using the ES I am running curl –XGET http:
//mysite.com:9200/stats/listingviews/_search?pretty Then count the hits for
a specific "_id": "hits" : { "total" : 1526, "max_score" : 1.0, "hits" : [
{ "_index" : "stats", "_type" : "listingviews", "_id" :
"IYSs1OmqSvK6gRDQr61j3w", "_score" : 1.0,
"_source":{"id":"1159","type":"listing","ua":"Mozilla/5.0 (Windows NT 6.1;
WOW64; rv:34.0) Gecko/20100101
Firefox/34.0","ip":"203.206.165.208","time":"2014-12-23 13:37:49"} }

When I test it on my dev environment (localhost) with only one node and
there is no load balance applied it works perfect, I always find this "_id"
and the count works pretty good, but on my production with load balance
activated I cannot find the results ("_id") on both servers ws001 and ws002
and it breaks my hits counting.

On my load balance servers I getting completely different results, I mean
("_id"), when I run: curl –XGET http:
//webserver1:9200/stats/listingviews/_search?pretty and curl –XGET http:
//webserver2:9200/stats/listingviews/_search?pretty. Also I already checked
the shads for each server and they are different.

At the end, the _ids found on both servers never match and definitely they
are not the same ids. I’m supposing that the replica on the load balance is
not working as replica and the ES is storing the data in both servers
separately. Even if the _ids are not on each server, the end result should
be our ability to count how many records there are (ie. where _source->id =
1159) but it seems to only get a count from ws001.

Which approach should I take to solve this issue, and be able to count my
hits on the production environment?

Thanks,

Carlos.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/9f7133f7-3bbb-4b7b-b298-d4bd125baf34%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

So these two nodes are their own separate clusters?
How are you indexing data into them? Are you using the auto ID generation
within ES or specifying your own?

On 28 January 2015 at 11:56, Carlos Henrique de Oliveira <
choliveira0604@gmail.com> wrote:

I have two Web Servers ws001 and ws002 working as load balance for
Elasticseach and I am trying to catch/count the hits for a specific page
which is something like this: mysite.com/listing/item-123/.

Using the ES I am running curl –XGET http: //
mysite.com:9200/stats/listingviews/_search?pretty Then count the hits for
a specific "_id": "hits" : { "total" : 1526, "max_score" : 1.0, "hits" : [
{ "_index" : "stats", "_type" : "listingviews", "_id" :
"IYSs1OmqSvK6gRDQr61j3w", "_score" : 1.0,
"_source":{"id":"1159","type":"listing","ua":"Mozilla/5.0 (Windows NT 6.1;
WOW64; rv:34.0) Gecko/20100101
Firefox/34.0","ip":"203.206.165.208","time":"2014-12-23 13:37:49"} }

When I test it on my dev environment (localhost) with only one node and
there is no load balance applied it works perfect, I always find this "_id"
and the count works pretty good, but on my production with load balance
activated I cannot find the results ("_id") on both servers ws001 and ws002
and it breaks my hits counting.

On my load balance servers I getting completely different results, I mean
("_id"), when I run: curl –XGET http:
//webserver1:9200/stats/listingviews/_search?pretty and curl –XGET http:
//webserver2:9200/stats/listingviews/_search?pretty. Also I already checked
the shads for each server and they are different.

At the end, the _ids found on both servers never match and definitely they
are not the same ids. I’m supposing that the replica on the load balance is
not working as replica and the ES is storing the data in both servers
separately. Even if the _ids are not on each server, the end result should
be our ability to count how many records there are (ie. where _source->id =
1159) but it seems to only get a count from ws001.

Which approach should I take to solve this issue, and be able to count my
hits on the production environment?

Thanks,

Carlos.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/9f7133f7-3bbb-4b7b-b298-d4bd125baf34%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/9f7133f7-3bbb-4b7b-b298-d4bd125baf34%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEYi1X-ZdMpsESDq8Dm6MurwmNX2_xS0oTTHjbMr1Y6KSewViw%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.

Hi Mark,
Yes, they are two separated nodes.

We are indexing the data via PHP:

public function resetListingsIndex(){
$es = new Elasticsearch\Client();

// delete listings
$deleteParams['index'] = 'listings';
@$es->indices()->delete($deleteParams);

// create listings index
$aElasticSearchParams=array();

$aElasticSearchParams = array(
    'index' => 'listings',
    'body' => array(
        'settings' => array(
            'number_of_shards' => 1,
            'number_of_replicas' => 0,
        ),
        'mappings' => array(
            'listing' => array(
                'properties' => array(
                    'reference_number' => array(
                        'type' => 'integer',
                        'analyzer' => 'keyword',
                    ),
                    'headline' => array(
                        "analyzer" => "standard",
                        "type" => "string",

                    ),
                    'headline' => array(
                        "analyzer" => "standard",
                        "type" => "string",

                    ),
                    'type' => array(
                        'type' => 'string',
                        'analyzer' => 'standard',
                    ),
                    'state' => array(
                        'type' => 'string',
                        'analyzer' => 'standard',

                    ),
                    //all other properties...
                )
            )
        )
    )

);

try{
    $aResult=$es->indices()->create($aElasticSearchParams);
    if($aResult['acknowledged']==true){
        return 'Successfully indexed';
    }
}
catch(Exception $e){
    return $e;
}

}

And yes we are using the auto ID generation within ES

Em quarta-feira, 28 de janeiro de 2015 12:06:51 UTC+11, Mark Walkom
escreveu:

So these two nodes are their own separate clusters?
How are you indexing data into them? Are you using the auto ID generation
within ES or specifying your own?

On 28 January 2015 at 11:56, Carlos Henrique de Oliveira <
cholive...@gmail.com <javascript:>> wrote:

I have two Web Servers ws001 and ws002 working as load balance for
Elasticseach and I am trying to catch/count the hits for a specific page
which is something like this: mysite.com/listing/item-123/.

Using the ES I am running curl –XGET http: //
mysite.com:9200/stats/listingviews/_search?pretty Then count the hits
for a specific "_id": "hits" : { "total" : 1526, "max_score" : 1.0, "hits"
: [ { "_index" : "stats", "_type" : "listingviews", "_id" :
"IYSs1OmqSvK6gRDQr61j3w", "_score" : 1.0,
"_source":{"id":"1159","type":"listing","ua":"Mozilla/5.0 (Windows NT 6.1;
WOW64; rv:34.0) Gecko/20100101
Firefox/34.0","ip":"203.206.165.208","time":"2014-12-23 13:37:49"} }

When I test it on my dev environment (localhost) with only one node and
there is no load balance applied it works perfect, I always find this "_id"
and the count works pretty good, but on my production with load balance
activated I cannot find the results ("_id") on both servers ws001 and ws002
and it breaks my hits counting.

On my load balance servers I getting completely different results, I mean
("_id"), when I run: curl –XGET http:
//webserver1:9200/stats/listingviews/_search?pretty and curl –XGET http:
//webserver2:9200/stats/listingviews/_search?pretty. Also I already checked
the shads for each server and they are different.

At the end, the _ids found on both servers never match and definitely
they are not the same ids. I’m supposing that the replica on the load
balance is not working as replica and the ES is storing the data in both
servers separately. Even if the _ids are not on each server, the end result
should be our ability to count how many records there are (ie. where
_source->id = 1159) but it seems to only get a count from ws001.

Which approach should I take to solve this issue, and be able to count my
hits on the production environment?

Thanks,

Carlos.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/9f7133f7-3bbb-4b7b-b298-d4bd125baf34%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/9f7133f7-3bbb-4b7b-b298-d4bd125baf34%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/8bb1a8b7-6972-49d3-8930-0ee50556ef8a%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

They are separate nodes, but are they in the same cluster, or are they
running as their own unique clusters? ie you have two clusters of one node
each, rather than one cluster with two nodes.

On 28 January 2015 at 15:42, Carlos Henrique de Oliveira <
choliveira0604@gmail.com> wrote:

Hi Mark,
Yes, they are two separated nodes.

We are indexing the data via PHP:

public function resetListingsIndex(){
$es = new Elasticsearch\Client();

// delete listings
$deleteParams['index'] = 'listings';
@$es->indices()->delete($deleteParams);

// create listings index
$aElasticSearchParams=array();

$aElasticSearchParams = array(
    'index' => 'listings',
    'body' => array(
        'settings' => array(
            'number_of_shards' => 1,
            'number_of_replicas' => 0,
        ),
        'mappings' => array(
            'listing' => array(
                'properties' => array(
                    'reference_number' => array(
                        'type' => 'integer',
                        'analyzer' => 'keyword',
                    ),
                    'headline' => array(
                        "analyzer" => "standard",
                        "type" => "string",

                    ),
                    'headline' => array(
                        "analyzer" => "standard",
                        "type" => "string",

                    ),
                    'type' => array(
                        'type' => 'string',
                        'analyzer' => 'standard',
                    ),
                    'state' => array(
                        'type' => 'string',
                        'analyzer' => 'standard',

                    ),
                    //all other properties...
                )
            )
        )
    )

);

try{
    $aResult=$es->indices()->create($aElasticSearchParams);
    if($aResult['acknowledged']==true){
        return 'Successfully indexed';
    }
}
catch(Exception $e){
    return $e;
}

}

And yes we are using the auto ID generation within ES

Em quarta-feira, 28 de janeiro de 2015 12:06:51 UTC+11, Mark Walkom
escreveu:

So these two nodes are their own separate clusters?
How are you indexing data into them? Are you using the auto ID generation
within ES or specifying your own?

On 28 January 2015 at 11:56, Carlos Henrique de Oliveira <
cholive...@gmail.com> wrote:

I have two Web Servers ws001 and ws002 working as load balance for
Elasticseach and I am trying to catch/count the hits for a specific page
which is something like this: mysite.com/listing/item-123/.

Using the ES I am running curl –XGET http: //mysite.com:9200/stats/
listingviews/_search?pretty Then count the hits for a specific "_id":
"hits" : { "total" : 1526, "max_score" : 1.0, "hits" : [ { "_index" :
"stats", "_type" : "listingviews", "_id" : "IYSs1OmqSvK6gRDQr61j3w",
"_score" : 1.0, "_source":{"id":"1159","type":"listing","ua":"Mozilla/5.0
(Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0","ip":"203.206.165.208","time":"2014-12-23
13:37:49"} }

When I test it on my dev environment (localhost) with only one node and
there is no load balance applied it works perfect, I always find this "_id"
and the count works pretty good, but on my production with load balance
activated I cannot find the results ("_id") on both servers ws001 and ws002
and it breaks my hits counting.

On my load balance servers I getting completely different results, I
mean ("_id"), when I run: curl –XGET http: //webserver1:9200/stats/listingviews/_search?pretty
and curl –XGET http: //webserver2:9200/stats/listingviews/_search?pretty.
Also I already checked the shads for each server and they are different.

At the end, the _ids found on both servers never match and definitely
they are not the same ids. I’m supposing that the replica on the load
balance is not working as replica and the ES is storing the data in both
servers separately. Even if the _ids are not on each server, the end result
should be our ability to count how many records there are (ie. where
_source->id = 1159) but it seems to only get a count from ws001.

Which approach should I take to solve this issue, and be able to count
my hits on the production environment?

Thanks,

Carlos.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/9f7133f7-3bbb-4b7b-b298-d4bd125baf34%
40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/9f7133f7-3bbb-4b7b-b298-d4bd125baf34%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/8bb1a8b7-6972-49d3-8930-0ee50556ef8a%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/8bb1a8b7-6972-49d3-8930-0ee50556ef8a%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEYi1X-Se8W7%2BVoYOmnrqw%3DXZQZG172SgJ7Hu038dp0%3DpXjXPg%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.

They are two Closters WS0001 and WS001 of one node each. In each server we
have a node like this:

WS001 => node.name: "elasticsearch_node_ws001"

WS002 => node.name: "elasticsearch_node_ws002"

Thanks.
Em quarta-feira, 28 de janeiro de 2015 16:37:28 UTC+11, Mark Walkom
escreveu:

They are separate nodes, but are they in the same cluster, or are they
running as their own unique clusters? ie you have two clusters of one node
each, rather than one cluster with two nodes.

On 28 January 2015 at 15:42, Carlos Henrique de Oliveira <
cholive...@gmail.com <javascript:>> wrote:

Hi Mark,
Yes, they are two separated nodes.

We are indexing the data via PHP:

public function resetListingsIndex(){
$es = new Elasticsearch\Client();

// delete listings
$deleteParams['index'] = 'listings';
@$es->indices()->delete($deleteParams);

// create listings index
$aElasticSearchParams=array();

$aElasticSearchParams = array(
    'index' => 'listings',
    'body' => array(
        'settings' => array(
            'number_of_shards' => 1,
            'number_of_replicas' => 0,
        ),
        'mappings' => array(
            'listing' => array(
                'properties' => array(
                    'reference_number' => array(
                        'type' => 'integer',
                        'analyzer' => 'keyword',
                    ),
                    'headline' => array(
                        "analyzer" => "standard",
                        "type" => "string",

                    ),
                    'headline' => array(
                        "analyzer" => "standard",
                        "type" => "string",

                    ),
                    'type' => array(
                        'type' => 'string',
                        'analyzer' => 'standard',
                    ),
                    'state' => array(
                        'type' => 'string',
                        'analyzer' => 'standard',

                    ),
                    //all other properties...
                )
            )
        )
    )

);

try{
    $aResult=$es->indices()->create($aElasticSearchParams);
    if($aResult['acknowledged']==true){
        return 'Successfully indexed';
    }
}
catch(Exception $e){
    return $e;
}

}

And yes we are using the auto ID generation within ES

Em quarta-feira, 28 de janeiro de 2015 12:06:51 UTC+11, Mark Walkom
escreveu:

So these two nodes are their own separate clusters?
How are you indexing data into them? Are you using the auto ID
generation within ES or specifying your own?

On 28 January 2015 at 11:56, Carlos Henrique de Oliveira <
cholive...@gmail.com> wrote:

I have two Web Servers ws001 and ws002 working as load balance for
Elasticseach and I am trying to catch/count the hits for a specific page
which is something like this: mysite.com/listing/item-123/.

Using the ES I am running curl –XGET http: //mysite.com:9200/stats/
listingviews/_search?pretty Then count the hits for a specific "_id":
"hits" : { "total" : 1526, "max_score" : 1.0, "hits" : [ { "_index" :
"stats", "_type" : "listingviews", "_id" : "IYSs1OmqSvK6gRDQr61j3w",
"_score" : 1.0, "_source":{"id":"1159","type":"listing","ua":"Mozilla/5.0
(Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0","ip":"203.206.165.208","time":"2014-12-23
13:37:49"} }

When I test it on my dev environment (localhost) with only one node and
there is no load balance applied it works perfect, I always find this "_id"
and the count works pretty good, but on my production with load balance
activated I cannot find the results ("_id") on both servers ws001 and ws002
and it breaks my hits counting.

On my load balance servers I getting completely different results, I
mean ("_id"), when I run: curl –XGET http: //webserver1:9200/stats/listingviews/_search?pretty
and curl –XGET http: //webserver2:9200/stats/listingviews/_search?pretty.
Also I already checked the shads for each server and they are different.

At the end, the _ids found on both servers never match and definitely
they are not the same ids. I’m supposing that the replica on the load
balance is not working as replica and the ES is storing the data in both
servers separately. Even if the _ids are not on each server, the end result
should be our ability to count how many records there are (ie. where
_source->id = 1159) but it seems to only get a count from ws001.

Which approach should I take to solve this issue, and be able to count
my hits on the production environment?

Thanks,

Carlos.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/9f7133f7-3bbb-4b7b-b298-d4bd125baf34%
40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/9f7133f7-3bbb-4b7b-b298-d4bd125baf34%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/8bb1a8b7-6972-49d3-8930-0ee50556ef8a%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/8bb1a8b7-6972-49d3-8930-0ee50556ef8a%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/9bf9bc38-44cb-4538-8c12-83240d4d509c%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

By default _id is auto generated by Elasticsearch -
http://www.elasticsearch.org/guide/en/elasticsearch/guide/current/index-doc.html#_autogenerating_ids.
It's done using a method similar to this
http://www.boundary.com/blog/2012/01/flake-a-decentralized-k-ordered-unique-id-generator-in-erlang/

Given you have two distinct clusters, I'd expect that the id's would be
different.

How are you load balancing across these two clusters?

On 29 January 2015 at 08:36, Carlos Henrique de Oliveira <
choliveira0604@gmail.com> wrote:

They are two Closters WS0001 and WS001 of one node each. In each server we
have a node like this:

WS001 => node.name: "elasticsearch_node_ws001"

WS002 => node.name: "elasticsearch_node_ws002"

Thanks.
Em quarta-feira, 28 de janeiro de 2015 16:37:28 UTC+11, Mark Walkom
escreveu:

They are separate nodes, but are they in the same cluster, or are they
running as their own unique clusters? ie you have two clusters of one node
each, rather than one cluster with two nodes.

On 28 January 2015 at 15:42, Carlos Henrique de Oliveira <
cholive...@gmail.com> wrote:

Hi Mark,
Yes, they are two separated nodes.

We are indexing the data via PHP:

public function resetListingsIndex(){
$es = new Elasticsearch\Client();

// delete listings
$deleteParams['index'] = 'listings';
@$es->indices()->delete($deleteParams);

// create listings index
$aElasticSearchParams=array();

$aElasticSearchParams = array(
    'index' => 'listings',
    'body' => array(
        'settings' => array(
            'number_of_shards' => 1,
            'number_of_replicas' => 0,
        ),
        'mappings' => array(
            'listing' => array(
                'properties' => array(
                    'reference_number' => array(
                        'type' => 'integer',
                        'analyzer' => 'keyword',
                    ),
                    'headline' => array(
                        "analyzer" => "standard",
                        "type" => "string",

                    ),
                    'headline' => array(
                        "analyzer" => "standard",
                        "type" => "string",

                    ),
                    'type' => array(
                        'type' => 'string',
                        'analyzer' => 'standard',
                    ),
                    'state' => array(
                        'type' => 'string',
                        'analyzer' => 'standard',

                    ),
                    //all other properties...
                )
            )
        )
    )

);

try{
    $aResult=$es->indices()->create($aElasticSearchParams);
    if($aResult['acknowledged']==true){
        return 'Successfully indexed';
    }
}
catch(Exception $e){
    return $e;
}

}

And yes we are using the auto ID generation within ES

Em quarta-feira, 28 de janeiro de 2015 12:06:51 UTC+11, Mark Walkom
escreveu:

So these two nodes are their own separate clusters?
How are you indexing data into them? Are you using the auto ID
generation within ES or specifying your own?

On 28 January 2015 at 11:56, Carlos Henrique de Oliveira <
cholive...@gmail.com> wrote:

I have two Web Servers ws001 and ws002 working as load balance for
Elasticseach and I am trying to catch/count the hits for a specific page
which is something like this: mysite.com/listing/item-123/.

Using the ES I am running curl –XGET http: //mysite.com:9200/stats/
listingviews/_search?pretty Then count the hits for a specific "_id":
"hits" : { "total" : 1526, "max_score" : 1.0, "hits" : [ { "_index" :
"stats", "_type" : "listingviews", "_id" : "IYSs1OmqSvK6gRDQr61j3w",
"_score" : 1.0, "_source":{"id":"1159","type":"listing","ua":"Mozilla/5.0
(Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0","ip":"203.206.
165.208","time":"2014-12-23 13:37:49"} }

When I test it on my dev environment (localhost) with only one node
and there is no load balance applied it works perfect, I always find this
"_id" and the count works pretty good, but on my production with load
balance activated I cannot find the results ("_id") on both servers ws001
and ws002 and it breaks my hits counting.

On my load balance servers I getting completely different results, I
mean ("_id"), when I run: curl –XGET http: //webserver1:9200/stats/
listingviews/_search?pretty and curl –XGET http:
//webserver2:9200/stats/listingviews/_search?pretty. Also I already
checked the shads for each server and they are different.

At the end, the _ids found on both servers never match and definitely
they are not the same ids. I’m supposing that the replica on the load
balance is not working as replica and the ES is storing the data in both
servers separately. Even if the _ids are not on each server, the end result
should be our ability to count how many records there are (ie. where
_source->id = 1159) but it seems to only get a count from ws001.

Which approach should I take to solve this issue, and be able to count
my hits on the production environment?

Thanks,

Carlos.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/9f7133f7-3bbb-4b7b-b298-d4bd125baf34%40goo
glegroups.com
https://groups.google.com/d/msgid/elasticsearch/9f7133f7-3bbb-4b7b-b298-d4bd125baf34%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/8bb1a8b7-6972-49d3-8930-0ee50556ef8a%
40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/8bb1a8b7-6972-49d3-8930-0ee50556ef8a%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/9bf9bc38-44cb-4538-8c12-83240d4d509c%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/9bf9bc38-44cb-4538-8c12-83240d4d509c%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEYi1X8vgz%2B7X7YQF1_LkCZe8xDnz8UNFiG2arpcAWJAdLiS7w%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.