Elasticsearch 1.0.1 _parent problem


(Mark-3) #1

Hi all:
I found a problem in 1.0.1, it seems I can not use the _parent keyword to
setup the mapping.
My mapping schema is like follows:
{"properties":
{"_parent":{"type":"jobPost"},

"jobPostId":{"type":"long","store":"yes","index":"not_analyzed","null_value":0},

"jobTitle":{"type":"string","store":"yes","index":"analyzed","null_value":""},
"experienceLevel":{"type":"string","store":"yes","index":"not_analyzed"}
}
}
I received the following exception:
org.elasticsearch.index.mapper.MapperParsingException: No handler for type
[jobPost] declared on field [_parent]

But it works fine at the version 0.90.9
Is it a bug of the version 1.0.1 or there's something wrong with my schema?
Can anyone help me, thanks.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/10610593-6497-4f07-adb3-654c735394f1%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(David Pilato) #2

I think it's because you put _parent inside properties and not outside.

My 2 cents

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 19 mars 2014 à 11:33:45, Mark (xueliang1985@gmail.com) a écrit:

Hi all:
I found a problem in 1.0.1, it seems I can not use the _parent keyword to setup the mapping.
My mapping schema is like follows:
{"properties":
{"_parent":{"type":"jobPost"},
"jobPostId":{"type":"long","store":"yes","index":"not_analyzed","null_value":0},
"jobTitle":{"type":"string","store":"yes","index":"analyzed","null_value":""},
"experienceLevel":{"type":"string","store":"yes","index":"not_analyzed"}
}
}
I received the following exception:
org.elasticsearch.index.mapper.MapperParsingException: No handler for type [jobPost] declared on field [_parent]

But it works fine at the version 0.90.9
Is it a bug of the version 1.0.1 or there's something wrong with my schema?
Can anyone help me, thanks.

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/10610593-6497-4f07-adb3-654c735394f1%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/etPan.5329796d.2f305def.97ca%40MacBook-Air-de-David.local.
For more options, visit https://groups.google.com/d/optout.


(Mark-3) #3

Hi David, Thank you very much, the problem is just as you described, I
moved the parent part out and it works, thanks a lot :slight_smile:

2014-03-19 19:03 GMT+08:00 David Pilato david@pilato.fr:

I think it's because you put _parent inside properties and not outside.

My 2 cents

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 19 mars 2014 à 11:33:45, Mark (xueliang1985@gmail.com) a écrit:

Hi all:
I found a problem in 1.0.1, it seems I can not use the _parent keyword to
setup the mapping.
My mapping schema is like follows:
{"properties":
{"_parent":{"type":"jobPost"},

"jobPostId":{"type":"long","store":"yes","index":"not_analyzed","null_value":0},

"jobTitle":{"type":"string","store":"yes","index":"analyzed","null_value":""},
"experienceLevel":{"type":"string","store":"yes","index":"not_analyzed"}
}
}
I received the following exception:
org.elasticsearch.index.mapper.MapperParsingException: No handler for
type [jobPost] declared on field [_parent]

But it works fine at the version 0.90.9
Is it a bug of the version 1.0.1 or there's something wrong with my schema?
Can anyone help me, thanks.

You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.

To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/10610593-6497-4f07-adb3-654c735394f1%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/10610593-6497-4f07-adb3-654c735394f1%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/bXE2iX2_bn8/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/etPan.5329796d.2f305def.97ca%40MacBook-Air-de-David.localhttps://groups.google.com/d/msgid/elasticsearch/etPan.5329796d.2f305def.97ca%40MacBook-Air-de-David.local?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CANbWZRORu7CpMzZ7pkXB6TnJfxDCsuNxj1GOgt-wEH1%3DKrAv%2Bw%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(system) #4