ElasticSearch 5.0 not installing on Windows


(Sameer Panicker) #1

I am trying to setup ES 5.0 on my machine. ES 2.2.0 was the prev. one which is working fine.

Now I am trying to upgrade it. During installation I am receiving this error.

Error: encountered environment variables that are no longer supported
Use jvm.options or ES_JAVA_OPTS to configure the JVM
ES_HEAP_SIZE=-Xms512m and -Xmx512m: set -Xms-Xms512m and -Xmx512m and -Xmx-Xms51
2m and -Xmx512m in jvm.options or add "-Xms-Xms512m and -Xmx512m -Xmx-Xms512m an
d -Xmx512m" to ES_JAVA_OPTS

What am I missing here ?


(Deepak Guleria) #2

Looking into this..


(David Pilato) #3

Have you seen this? https://www.elastic.co/guide/en/elasticsearch/reference/master/breaking_50_packaging.html#_jvm_options


(Sameer Panicker) #4

the jvm.config file looks OK. Do I need to make any modifications here ?


(David Pilato) #5

You are probably setting ES_HEAP_SIZE somewhere but you should not do it anymore and use ES_JAVA_OPTS instead.


(Jason Tedor) #6

@dadoonet is correct, but you should prefer jvm.options over using an environment variable. Note that your unsupported ES_HEAP_SIZE setting is not in the correct format to begin with though.


(Sameer Panicker) #7

I am not able to figure out where is the ES_HEAP_SIZE option set. I tried looking into the Env. Variables, YML Files. But couldnt get any references. Also the jvm.options file also looks clear.

These are the steps I have followed inorder to setup ES 5.0.

  1. Downloaded the Windows zip - https://www.elastic.co/v5
  2. Unzipped the ES folder.
  3. Open CMD in Admin mode.
  4. Navigated to the ES bin path and execute CMD line - service.bat install

I am able to load kibana 5 properly. The prb is only with ES.

Not getting how and where I need to set these options ?


(Jason Tedor) #8

You clearly configured this somewhere, I don't know where. You should start by checking your system environment variables and the service (service.bat manager).


(Sameer Panicker) #9

I tried looking for that variable name but couldnt find it anywhere.

Can you please let me know what has changed in the installation process for Kibana between 4.5/5.0 ?


(Jason Tedor) #10

You'll have better luck with that question in the Kibana category.


(Костя Хомко) #11

you can try to find this variable. just open cmd and paste: set| findstr "HEAP"
If you will get the positive result than go to the PC->Properties->Advanced->Environment Variables->Scroll down and delete the "ES_HEAP_SIZE".


(system) #12